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Description and Objectives

Course Description
The MicroStation CONNECT Edition Basics course is designed for the new MicroStation CONNECT Edition user and builds a solid foundation 
in the concepts, tools and features found in the MicroStation drawing environment. Starting with setting up a drawing and concluding with 
printing, you will walk through typical workflows using the tools and features in MicroStation CONNECT Edition.

Skills Taught
 Using General Tools 

 Defining Element Attributes 

 Controlling the Display of Designs 

 Using AccuDraw and AccuSnap 

 Creating Drawing Elements 

 Selecting Elements 

 Manipulating Elements

 Modifying Elements 

 Working with Cells 

 Annotating Designs 

 Composing Designs and Drawings 

 Printing and Publishing
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A Word about the WorkSpace...
Note that the exercises contained in this workbook are designed to use a custom WorkSpace, BentleyCONNECTTraining, and an example 
WorkSet from this WorkSpace, MSBasics.

The default installation folder for this dataset is:

C:\BentleyCONNECTTraining\

For more information on installing and configuring a training dataset for MicroStation CONNECT Edition, please see the course:

Before You Begin: Configuring the Dataset for a MicroStation CONNECT Edition Course



Practice Workbook
This workbook is designed for use in Live instructor-led training and for OnDemand selfstudy. 
The explanations and demonstrations are provided by the instructor in the classroom, or in the OnDemand 
eLectures of this course available on the Bentley LEARN Server (learn.bentley.com).

This practice workbook is formatted for on-screen viewing using a PDF reader. 
It is also available as a PDF document in the dataset for this course.
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Using General Tools
This workbook contains exercises that cover the basics of MicroStation CONNECT Edition, such as using the 
interface, working with tools, creating new DGN files, getting information about elements, and measuring 
elements.
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Start with MicroStation CONNECT Edition

This exercise will show you how to start MicroStation, select a workspace and workset, and open a DGN file.

1. Start MicroStation CONNECT Edition.

When MicroStation CONNECT Edition is started for the first time, the welcome page is opened. 
This page introduces the user to MicroStation and provides links to various examples, learning content hosted on the Bentley 
LEARNserver, news and announcements, and links to various social media websites.

The welcome page is only presented the first time MicroStation CONNECT Edition is started. Each subsequent time MicroStation is 
started, you will be taken directly into the work page.

2. To begin working in MicroStation, place your cursor over the arrow on the right side of the application window and click Start a work 
session.,

The welcome page will slide to the left, displaying the MicroStation work page.

Hint: It is possible to return to the welcome page at any time by placing your cursor over the arrow on the left side of the work page and 
clicking Examples, Courses and News.
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On the work page, you can select a workspace and a workset.

 A workspace is a container that is used to group worksets and may be used to represent any variety of things, such as a client, a 
department, or a specific asset, such as a plant or building.

 A workset represents a specific project. By selecting a workset, MicroStation can be customized for a specific project or job. When a 
workset is active, the tools and resource files you need for that project or job are available. 

Workspaces and worksets are usually set up by an administrator.

3. On the work page, set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

Note: If no workspaces and worksets are set up, you can select No Workspace (and No WorkSet).

4. To open a design file, click Browse and navigate to the folder where you installed the dataset, by default C:\BentleyCONNECTTraining.

5. Then continue to the \WorkSets\MSBasics\dgn\01 - Using General Tools folder.

6. Ensure that the filter at the bottom is set to CAD Files (*.dgn; *.dwg; *.dxf).

With MicroStation, you create DGN files (design files) with the extension .dgn. 
It is also possible to open and edit AutoCAD DWG (*.dwg) and DXF files (*.dxf).

7. Click on the file named MicroStation_Basics.dgn and click Open.

You may be presented with a No WorkSet Alert message. That’s because this file is not associated with the active workset yet.

8. Select Use active WorkSpace ..., WorkSet ... and click Open.
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The file is opened, displaying the MicroStation CONNECT Edition user interface. 
This file is now ‘branded’ to the active workspace/workset. Each subsequent time this file is opened, MicroStation will verify that this 
workspace/workset is active. If it is not, the user will be prompted to activate this workspace/workset.

The DGN file MicroStation_Basics.dgn is the active design file now. You can open only one design file at a time.
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Explore the MicroStation interface

The MicroStation CONNECT Edition features a ribbon-style interface consisting of the following components.

1. Continue in MicroStation_Basics.dgn.

On the ribbon you see various ribbon tabs that contain all kinds of tools.

2. Click on the tabs View, Annotate, Attach, et cetera, to explore them. Don’t click on the File tab yet.

Which tabs are available depends on the ribbon workflow that you select. 
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3. Observe in the upper left corner if the Drawing workflow is active.

4. Expand the drop-down menu, select one of the other workflows, and explore the ribbon tabs again.

The ribbon workflows are used to group collections of tools into logical workflows. 

 The Drawing workflow and the Task Navigation workflow are standard workflows, delivered with MicroStation.

 The LEARNing CONNECT workflow is a custom workflow that contains a subset of the standard Drawing workflow, for learning 
purposes. It is defined in the course dataset and only available within the MSBasics workset.

5. Set the active workflow to Drawing again.

To the right of the ribbon workflow you find the Quick Access Toolbar. It contains frequently used commands such as Open, Save, Undo, 
and Print. These tools are always available, independent of the active workflow.

6. Explore the tools in the Quick Access Toolbar.

The MicroStation Help is integrated in the ribbon and can be accessed at any time by clicking the Help icon in the upper right corner. The 
Help is a web-based environment and is opened in the default web browser.

7. Click the Help icon and explore the Help in your web browser.

The Search Ribbon function can be used to find tools or dialogs. It can search across multiple ribbon workflows and ribbon tabs, search 
Help topics, and access Bentley Communities.
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To search, enter the partial or full name of the tool or dialog and you will get a list of results in a menu below the Search Ribbon field.

8. Type line in the Search Ribbon field.

9. In the results, select Place SmartLine in the Ribbon category.

This activates the Place SmartLine tool.
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The File tab is a special tab, as it brings you to the Backstage.

10. Click on the File tab.

You are presented with the backstage.

The Backstage is where you can perform different operations such as managing your document and settings, importing and exporting 
files, setting your user preferences, and so on. It also contains tools to open additional tool boxes and provides access to printing and 
publishing features.
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11. In the blue menu on the left, select Settings, in the next column select User, and then Preferences. 
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The Preferences dialog opens. User preferences allow you to control the operation of MicroStation without affecting other team members. 
You can, for example, set the background to black or white, in the View Options category.

12. Close the Preferences dialog.
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13. To return to the active design, click the arrow in the upper left corner on the Backstage.
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Explore the models in a DGN file

A DGN file contains at least one model, but may contain multiple models. A model is a separate graphical space within 
a DGN file. A model in a DGN file is equivalent to a worksheet in an Excel file. A model can be 2D or 3D.

1. Continue in MicroStation_Basics.dgn.

Generally, only one model is displayed, the active model. That is where you can create or manipulate graphical elements, such as lines, 
circles, and shapes. To open a model, you can use the Models dialog.

Hint: Note that you can display other models contained in the active DGN file (or in another DGN file) by attaching them as references to 
the active model. This is explained in the module 11 - Composing Designs and Drawings.

2. To open the Models dialog click the Models icon on the Home tab in the Primary group.

This DGN file contains a whole lot of models.
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3. In the Models dialog, double-click the Element Creation model in the list to open it.

This is a 2D model. The name of the active model is displayed in the title bar of the view.

4. Scroll down in the models list and double-click the Office Building model to open it as the active model.

Hint: You can click on the Name column header to sort the models alphabetically by name.

This is a 3D model that is displayed in four different ways, in four view windows.

5. Open the Precision Input with AccuDraw model by double-clicking it in the list.

This model is empty.

6. Close the Models dialog.
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Work with tools

In this exercise, you will try out some drawing tools and practice how to use them. 
Working with most MicroStation tools consists of the following steps:

 Select a tool.

 Adjust the tool settings.

 Follow the prompt on the status bar to use the tool.

1. Continue in MicroStation_Basics.dgn, in the Precision Input with AccuDraw model.

First, you will draw some lines with the Place SmartLine tool.

2. On the Home tab, in the Placement ribbon group, click the Place SmartLine icon to activate this tool.

3. Read the prompt at the lower left of the application window, in the status bar: Place SmartLine > Enter first vertex.

4. Click somewhere in the empty view window to define the start point of the line. Do not keep the mouse button pressed!

5. Read the prompt again: Place SmartLine > Enter next vertex or reset to complete.

6. Click in the view to define the end point of the line segment.

A point that you place by clicking the left mouse button is called a data point. The left mouse button is called the data button.

7. Continue by defining more vertices, thus creating a line string.

8. To stop placing line segments click the right mouse button.

The right mouse button is called the reset button. You click the reset button to stop with an action and resume from the beginning.
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Note that the Place SmartLine tool is still active and asks for the first vertex of a new line.

9. Draw some more lines and line strings.

Next, you will create a block.

10. On the Home tab, in the Placement ribbon group, select the Place Block tool.

11. Read the prompt: Place Block > Enter first point.

12. Define the first corner of the block with a data point and move the mouse to see that a block is being created instead of a line.

13. Read the prompt: Place Block > Enter opposite corner.

14. Define the opposite corner to complete the block. Note that you do not need to reset this time.

Let’s create a circle then.

15. In the Tasks dialog, in the Drawing task, select the Place Circle tool.

16. Read the prompt: Place Circle By Center > Identify center point.

17. Define the center point of the circle and move the mouse to see that this time a circle is being created.
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18. Following the prompt, define the circle radius by entering a data point on the circle’s edge.

Hint: To define an exact distance, you can use AccuDraw. This is explained in the module Using AccuDraw and AccuSnap.

There are other methods to define a circle, for example by defining three points on the circle’s edge. You can select the desired method in 
the tool settings window.

19. With Place Circle still active, read the tool settings.

20. Set the method to Edge and read the changed prompt: Place Circle By Edge > Identify first point on circle.

21. Enter a data point to define the first point on the circle’s edge.

22. Read the prompt and enter another data point to define the second point on the circle’s edge.

When you move the pointer, a dynamic circle is displayed.

23. Following the prompt, enter a third data point to complete the circle.
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Each tool has its own tool settings. When you select another tool, the tool settings are automatically updated.
Always check these first and adjust them, if needed. Then read the prompt and continue with the tool.

24. Select Place Block again and note the tool settings.

25. Set the method to Rotated and create another block, following the prompts.
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Delete elements and undo actions

In this exercise, you will practice how to select and delete elements, and how to undo or redo actions.

1. Continue in MicroStation_Basics.dgn, in the Precision Input with AccuDraw model.

Let’s delete some elements that you have created in the previous exercise.

2. Select the Delete Element tool on the Home tab, in the Modify ribbon group.

3. Click on several elements to delete them from the design.

MicroStation remembers everything you do. You can always retrace your steps by using the Undo tool.

4. In the Quick Access Toolbar, select the Undo tool (or press Ctrl + Z on your keyboard) several times until all elements are displayed again.

Hint: In case you have clicked Undo too many times, you can use Redo (or press Ctrl + R) to undo your Undo action.

Instead of deleting elements one by one, you can select multiple elements prior to selecting the Delete Element tool.

5. On the Home tab, in the Selection ribbon group, select the Element Selection tool.
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6. In the tool settings, select the first icon in both rows (Individual and New).

7. With the left mouse button pressed, drag a selection rectangle from left to right around some elements.

All elements that are completely inside the selection rectangle are selected.

Hint: When you drag a selection rectangle from right to left, the elements that are partly within the selection rectangle are also selected 
(overlap). 
To clear the selection set, just click somewhere in the view, but not on an element.

8. Select Delete Element to delete the selected elements.

9. Select Undo (or press Ctrl + Z) to undo the deletion of the elements.
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Save and compress a DGN file

In MicroStation, you do not have to save your design changes, as MicroStation saves each change as it is made in the 
active DGN file. But before closing a DGN file or opening another one, you probably also want to save the design file 
settings. In addition, you can compress a design file.

1. Continuing in MicroStation_Basics.dgn, in the Precision Input with AccuDraw model, ensure that the newly created elements are visible.

You will close this DGN file and reopen it, to see what happens.

2. Select File and on the backstage select Close.

You’ve returned to the work page. The last opened file is now listed in the Recent Files list.

3. Click on the MicroStation_Basics.dgn file to reopen it.

The file is opened again, but probably a different model is displayed than the one you were working in. That’s because you did not save 
the design file settings. But don’t worry, the newly added elements are automatically saved!

4. Open the Models dialog by clicking the Models icon on the Home tab in the Primary ribbon group.

5. Double-click the Precision Input with AccuDraw model in the list to open it.



Copyright © 2016 Bentley Systems, Incorporated 21DO NOT DISTRIBUTE - Printing for student use is permitted

The elements you created earlier in this model are visible again.

6. Select Save Settings in the Quick Access Toolbar (or press Ctrl + F) to save the current design file settings with your design file.

7. Close the DGN file and reopen it.

This time, the Precision Input with AccuDraw model is opened immediately.

Hint: By default, design changes are saved automatically and design file settings not. 
If you want to change these preferences, click on the File tab, then on the backstage select Settings > User > Preferences, and in the 
Preferences dialog select the Operation category. Check or uncheck the Save Settings on Exit and the Auto-save Design Changes 
preferences.
User preferences are not stored in the DGN file, but in a separate user preference file (personal.upf).

Note: In most cases, it is a best practice to save settings when they are changed, rather than waiting until the end of a design session. 
This allows you to save just the desired settings. By waiting until the end of a design session, it is possible that settings may get saved 
that you do not want to permanently change

Before archiving a DGN file, it is a good practice to compress it. Compressing a DGN reduces its size by purging deleted elements. It also 
clears the undo buffer, so you will no longer be able to undo and redo.
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8. In the Quick Access Toolbar, select Compress Options.

9. In the Compress Options dialog, leave all options unchecked and click Compress.

The DGN file size is reduced, because all deleted elements are really removed from the file now.

10. Click on the File tab and then select Close to close MicroStation_Basics.dgn.
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Create a new DGN file

A new design file is created by copying an existing seed file, which serves as a template. A seed file may contain one or 
more models (2D and/or 3D), with preset working units and other settings. A seed file may also include geometry, for 
example, a border.

1. Continuing in MicroStation CONNECT Edition, on the work page click New File.

2. In the New dialog, navigate to the \MSBasics\dgn\01 - Using General Tools folder.

This is the location where you will create the new file.

The most important thing when creating a new design file is to select the correct seed file. Generally, seed files are prepared by a CAD 
administrator. Different seed files can be available for different purposes or projects.

11. In the New dialog, click the Browse button in the lower right corner to open the Select Seed File dialog.

12. Navigate to the dataset’s seed folder \MSBasics\Standards\Seed.

13. Select the seed file ModelMetricGeneral.dgn and click Open.

The selected seed file is now displayed in the Seed field at the bottom of the New dialog.

14. Ensure that the Save as type setting is set to MicroStation DGN Files (*.dgn), so that the correct extension will be appended to the file 
name.

15. In the File name field, type training and click Save.
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The new DGN file is created and opened.
The seed file that you used contains four models, so this new DGN file contains the same four models. 

16. Open the Models dialog to view the list of models.

17. Double-click the 2D Design model to open it.

18. Select Save Settings in the Quick Access Toolbar (or press Ctrl + F).
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Create a new model

Instead of creating a new DGN file, it is also possible to create a new model within the active DGN file.

1. Continue in training.dgn, in the 2D Design model.

2. In the Models dialog, click the first icon Create a new model.
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3. In the Create Model dialog, set the following:

Type: Design + 2D

Name: Floor Plan

4. Leave the other settings as they are and click OK.

The new design model is added to the list and opened as the active model.

Note: When creating a new model without using a seed model, the model settings are derived from the active model. Another option is to 
set the type to Design From Seed and select a model from one of your seed files.
Or you can copy an existing model by clicking the second icon in the Models dialog: Copy a model.



Copyright © 2016 Bentley Systems, Incorporated 27DO NOT DISTRIBUTE - Printing for student use is permitted

Explore design file settings

In this exercise, you will explore several design file settings. Generally, these settings are already set correctly in the 
seed file that you use when creating your design file. 
These design file settings are stored within the active DGN file when you select Save Settings in the Quick Access 
Toolbar (or press Ctrl + F).

1. Continue in training.dgn, in the Floor Plan model.

2. Click on the File tab to go to the backstage.

3. In the menu on the left click Settings, in the next column click File, and then select Design File Settings.
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This opens the Design File Settings dialog, where you can change design-file specific settings. Some of these settings are in fact model-
specific, such as the working units.

4. Select the Working Units category.

Working units define the real-world units that you work with in the active model. Typically, the working units are predefined in the seed file 
and will not require any adjustment.
Working units are composed of master units (MU) and sub units (SU) and can be set to English units or metric units. When using metric 
units, you generally only use the master unit.
Changing the working units does not affect the size of elements in the model. You can draw, for example, in feet and inches, and then 
change the master unit and sub unit to Meters and Millimeters to get the metric measurements.

Note: Do not change the Resolution setting in the Advanced Unit Settings dialog (opens when you click the Edit button), as this does 
affect the size of existing elements.

5. Note that the master unit and sub unit in this model both are set to Millimeters, a metric unit, because you used a metric seed file 
ModelMetricGeneral.dgn to create training.dgn.

The Format and Accuracy settings define the coordinate and distance readout in the status bar and dialogs.

6. Ensure the Format is set to MU, so that only master units are displayed.

7. Change the Accuracy to three decimals: 0.123.

This does not affect the accuracy of calculations, only the precision with which the units are displayed.
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8. In the left menu, select the Angle Readout category.

This is where you can change the format and accuracy of the angle readout, if needed.

9. Select the Color category.

Here you can set the highlight color with which elements are displayed when you select them.
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10. Change both the Element Highlight Color and the Selection Set Color to magenta.

11. Click OK to close the dialog.

12. Click the arrow in the upper left corner on the backstage (or press Esc) to return to the active design.

13. Select Save Settings in the Quick Access Toolbar (or press Ctrl + F) to save the changed design file settings in the active DGN file 
training.dgn.



Copyright © 2016 Bentley Systems, Incorporated 31DO NOT DISTRIBUTE - Printing for student use is permitted

Get information about elements

In this exercise, you will practice how to get information about elements in a model.

1. To open another file click on the File tab and on the backstage click the Browse button.

2. Open Measuring_Elements.dgn and select Use active WorkSpace ..., WorkSet ... if the No WorkSet Alert message appears.

3. Ensure that the Measuring Elements model is open.

4. Select the Element Selection tool in the Selection group on the Home tab.

5. Hold the pointer still on one of the circles, without clicking.
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Information about the highlighted element appears in a pop-up window: the element type and the level on which the element is drawn.

6. Explore some other elements by hovering the pointer over them one by one.

If you want more detailed information about an element, you can do the following.

7. Right-press on one of the blue shapes around the circle and in the context menu select Properties.

Hint: If the context menu doesn’t show, keep the mouse button pressed a little bit longer.
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This opens the Properties dialog, with information about the selected element.
The information about the shape is displayed on several panels in the Element Information dialog.

8. Explore the information on the panels.

9. In the view window, select one of the orange steps at the bottom of the design.
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This is a complex shape that is composed of two line strings and two arcs.

Hint: Note that you also can get information about the separate elements that together form the complex shape, by selecting that element 
in the top section.

10. Close the Properties dialog. 

11. Clear the selection by clicking somewhere in the view window (not on an element).
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Measure elements

To measure a length, distance, radius, diameter, angle, or area in your design, you can use the Measure tools. You can 
find these tools on the Analyze tab, in the Measure ribbon group.

1. Continuing in Measuring_Elements.dgn, in the Measuring Elements model, zoom in to the upper part of the design.

2. On the Analyze tab, in the Measure ribbon group, select the Measure Length tool.

This tool makes it very easy to measure the length of an element.

3. Select one of the vertical lines at the top.
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4. Read the length in the tool settings window: 71.5200m.

In addition, the direction (angle) of the selected line is displayed.
Both length and angle are also shown in the status bar, in the message field.

For a closed element the perimeter is measured.

5. Select one of the circles or shapes and read the perimeter.

If you want to measure the total length of several elements, you can select them in advance. 
Let’s measure the length of the figure at the upper right, which is composed of separate lines and an arc.
There is an easy way to activate the Element Selection without the need to switch from one ribbon tab to another.

6. Press the space bar to open the Popups toolbox, where you can access the most common tools or open a frequently used ribbon group.

7. Click the first icon on the second row to activate the Element Selection.

8. Drag a selection rectangle around the figure to select all elements in it.
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9. Select Measure Length and read the total length of the selected elements in the tool settings window (or in the status bar): 206.4675m.

10. Click somewhere in the view window to return to the Element Selection and click again to clear the selection.

There are several ways to measure the distance between two points or elements.

11. On the Analyze tab, in the Measure ribbon group, select the Measure Distance tool.

12. In the tool settings, ensure the Method is set to Between Points.

Let’s measure the distance between the two solid vertical lines. To measure the distance exactly you will snap to the end points of both 
lines.

13. Move the pointer close enough to the lower end point of the first line until a bold, yellow X displays.

14. Left-click to snap to this point.

15. Move the pointer to the lower end point of the second line until the bold, yellow X appears.

16. Left-click to snap to the second end point.

17. Read the measured distance in the tool settings: 19.2000m.
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18. To continue measuring distances snap to another point, for example, on the figure on the right.

19. Read the information in the tool settings.

The distance between the last two points (66.4597m) as well as the total distance from the start point (85.6597m) is displayed.

20. Reset to stop measuring.
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Hint: By using the other methods of the Measure Distance tool you can measure a distance along or perpendicular to an element, or 
measure the minimum or maximum distance between two elements.

There are also tools to measure the radius of a circle or arc, or the angle between line segments.

21. On the Analyze tab, in the Measure ribbon group, select the Measure Radius tool.

22. Select one of the circles, or the arc at the upper right, and read its radius and diameter in the tool settings.
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23. In the Measure ribbon group, select the Measure Angle tool.

24. Following the prompt, select a first line segment, for example, in one of the blue shapes.

25. Select a second line segment and read the angle between both segments in the tool settings.

Finally, you will measure the area of a closed element.

26. In the Measure ribbon group, select the Measure Area tool.

27. In the tool settings, ensure the Method is set to Element.
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28. Select one of the circles or shapes and read its area and perimeter in the tool settings.

Hint: This tool has additional methods to measure the area defined by overlapping closed elements or by multiple non-closed elements. 
You can find more information about these methods in the Annotating Designs module, where hatching and patterning areas is explained.

29. Click on the File tab and then select Close to close Measuring_Elements.dgn.
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Defining Element Attributes
This workbook contains exercises to practice how to define the appearance of elements by assigning them 
specific attributes and how to change these attributes afterwards.
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Define element attributes and use ByLevel symbology

When creating new elements in a design, they are assigned attributes that control their appearance. The general 
element attributes are set in the Attributes group, on the Home tab.

 Active Level – Specifies the level on which new elements are placed.

 Active Color – Specifies the color of new elements.

 Active Line Style – Specifies the line style of new elements: standard (0-7) or custom.

 Active Line Weight – Specifies the line weight of new elements (0-31).

An important element attribute is the level on which an element is placed. You need to place the correct types of 
elements on the correct levels, as determined by your organization’s standards. The display of levels can be turned on 
and off, so that you can see (or print) only the information you want.
Best practice is to have the color, line style, and line weight of an element defined by the level on which it is placed. This 
is called ByLevel symbology. 

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Element_Attributes.dgn from the \MSBasics\dgn\02 - Defining Element Attributes\ folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.
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3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Default model by double-clicking it in the list.

5. In the Attributes group on the Home tab, set the active level to Geometry.

Hint: To easily find the level in the list, you can type part of the level name in the Search Levels field.

To ensure that the color, line style, or line weight of an element is defined by the level on which the element is placed, you have to set the 
active color, line style, or line weight to a specific value: ByLevel. In that case, the color, line style, and line weight will automatically 
change when you change the active level.
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6. To set the active color to ByLevel, click the Active Color icon and select ByLevel below the color table.
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7. Set both the active line style and the active line weight to ByLevel as well.

8. Note that the three icons show a small stack of levels now. The values reflect the color (6), line style (0), and line weight (2) that are 
assigned to the level geometry. 

Note: Which color, line style, and line weight is assigned to a level is generally managed by an administrator.
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9. Select Place SmartLine (Home tab > Placement group) and draw some lines on the level geometry.

10. Change the active level to the land level.

Note that the color, line style, and line weight automatically change as well. They now reflect the color (2), line style (4), and line weight (1) 
of the level land.

11. Draw some lines on the land level.

12. Then change the active level to sea and draw some lines on that level.

The elements on the level sea have the line style { Diamond } assigned, but this line style is hardly visible. The reason is that the global 
line style scale is not set correctly.
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13. Open the Models dialog by clicking the Models icon on the Home tab, in the Primary group.

14. In the Models dialog, right-click the Default model (the active model) and select Properties.

15. In the Properties dialog, on the General panel, set the following:

Line Style Scale: Global Line Style Scale

Global Line Style Scale Factor: 10

Hint: Another option is to set the Line Style Scale to follow the Annotation Scale, and set the Annotation Scale to 1:10. The annotation 
scale is used to scale texts and other annotations depending on the print scale.
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The elements with the { Diamond } line style are immediately updated.

Note that the line style of the green elements did not change. That’s because these are drawn with a standard line style, in this case line 
style 4. Standard line styles are not scalable.

 Custom line styles are scalable and become larger or smaller when you zoom in or out. 

 Standard line styles (0-7) are defined in screen units and are not scalable. They are not truly WYSIWYG (“what-you-see-is-what-
you-get”): they do not change size when you zoom in or out. That’s why it is recommended that you use custom line styles.

16. Select the Element Selection tool in the Selection group on the Home tab.

17. Right-press on one of the diamond lines and in the context menu select Properties.

This opens the Properties dialog, with information about the selected element.
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The color, line style, and line weight of this element are set to ByLevel and reflect the values that have been assigned to the level sea.

18. With Element Selection still active, select one of the orange lines on the level geometry.

The color, line style and line weight of this element are also set to ByLevel, so this line is displayed with the color, line style and line weight 
of the level geometry.

Note that the line weight of this level is set to 2. 
The line weight defines the thickness of an element, in screen units. At printing time, each line weight is mapped to a certain print width, 
as defined in the printer driver configuration.

So generally, you should not have to change the active color, active line style, and active line weight anymore, as they will follow the 
active level. Only when you want to override the ByLevel color, line style, or line weight, you can select a ‘hard’ value.
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Change and match element attributes

Using the Change Element Attributes tool you can change one or more attributes of an element. 
If the ByLevel symbology method is being used, in fact you only need to change the level of an element. The color, line 
style and line weight will then update accordingly.

To set the active element attributes so they match those of an existing element in the design, you can use the 
SmartMatch tool or the Match Element Attributes tool.

You can find these tools on the Home tab, in the Modify group.

1. Continue in Element_Attributes.dgn, in the Default model. 

2. Select the Element Selection tool in the Selection group on the Home tab.
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3. Hold the pointer still on one of the lines (without clicking) and note on which level it is.

You will change the level of this line.

4. Select the Change Element Attributes tool on the Home tab, in the Modify group, and set the following:

Active Attributes: enabled

Level: enabled + set to geometry
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Color: disabled

Style: disabled

Weight: disabled

Note that when you change the level in the tool settings, the active level in the Attributes group on the Home tab also changes. That is 
because Active Attributes is enabled.

5. Following the prompt, select one of the green dashed lines on the level land.

As the line is changed to the level geometry, its color, line style and line weight automatically change as well.

Suppose that you want to move this line to the same level as the blue diamond lines, but you don’t know which level that is.

6. Continue with the Change Element Attributes tool, with the same tool settings.

7. This time, in the tool settings, first click the eyedropper icon at the top.
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This activates the Match Element Attributes tool, allowing you to identify an element to match.

8. Following the prompt, select one of the blue diamond lines.

Note that the active level has changed to sea.

9. Then select the line that should be changed to the sea level. 

It changes to a blue diamond line.
So instead of setting the destination level (= active level) manually, it was now set by picking an element on that level.

Another option is to use the SmartMatch tool that you can activate in the Modify group on the Home tab. 

This is a very powerful tool, because you can use it to set all active element attributes to match with an existing element. It does not only 
set the active level, color, line style, and line weight, but also the active text, dimension, hatch, pattern, and other settings! You can then 
easily create a new element that looks exactly the same as an existing element.

10. Select the SmartMatch tool and click successively on several lines on different levels.

Note how the active settings in the Attributes group on the Home tab change, depending on the element you select.

There is another quick method to change the level (or other attribute) of one or more elements.

11. With the Element Selection tool, select several elements.
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12. Then change the active level in the Attributes group to land.

13. Left-click to clear the selection set.

The level and the appearance of the selected elements is changed.
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Create filled elements

When creating a closed element, such as a circle or a shape, an additional attribute is available in the tool settings: the 
fill attribute. This attribute can also be changed afterwards.

There are three options for the fill type:

 None – The area of the element inside the outline is not filled.

 Opaque – The element is displayed as a solid shape. The outline has the same color as the fill.

 Outlined – The element is displayed as a solid shape. You can select a fill color that is different from the active color 
that is used for the outline.

1. Continue in Element_Attributes.dgn, in the Default model.

2. Set the active level to geometry.

3. Select Place Block (Home tab > Placement group) and set the following:

Method: Orthogonal

Area: Solid

Fill Type: Outlined

Fill Color: 4

4. Enter two data points to define the block.

The block is displayed as a filled rectangle.
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If not, you should check the view attributes for the current view.

5. Click View Attributes, the first icon in the view control bar at the top of view 1, to open the View Attributes dialog (or press Ctrl + B).

6. Ensure that the Fill view attribute is enabled for view 1, otherwise the filled area is not displayed.

7. Close the View Attributes dialog.

To change the fill type of an existing element, a special Change tool is available: Change Element Fill Type.

8. Select the Change Element Fill Type tool on the Home tab, in the Modify group.

9. In the tool settings, set the following:

Fill Type: Opaque

Fill Color: Gradient
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10. Select the filled block.

The fill is changed to a gradient fill and the outline is not displayed anymore.
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Apply transparency and priority

When elements in a design are on top of each other, especially filled elements, you can use the element attributes 
transparency and priority to make them visible in the way you want.

 Transparency – Specifies the transparency of an element. Transparency may vary from 0% (no transparency) to 
100% (almost complete transparency).

 Priority – Determines the order in which elements are displayed in a view (only in 2D). The element priority value 
may vary from -500 to 500. The elements assigned the highest element priority value are displayed in the front, 
while the elements assigned the lowest values are displayed at the back.

Note: Transparency as well as display priority can not only be applied to elements, but also to levels and references.

1. Continue in Element_Attributes.dgn, in the Default model.

2. Ensure that the Active Transparency and the Active Priority in the Attributes group on the Home tab are both set to 0.

3. Draw some filled blocks or circles that overlap each other.

You will create another filled block that should be displayed behind the elements you have just created.

4. Click the Active Priority icon in the Attributes group and set the value to ‐100.

5. Place another filled block that overlaps the existing elements.
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Because of its lower priority, the new block is displayed behind the other elements.

You will change the priority of – in this image – the yellow block to display it in front of the other elements.
To do this, you can use the Change Element Attributes tool, but there is another fast way to change an element attribute afterwards.

6. With Element Selection, select the block whose priority you want to change.

7. Click the Active Priority icon in the Attributes group and set the value to 100.

8. Enter a data point to clear the selection.

When you change an active element attribute in the Attributes group, such as the active color, level, or priority, while elements are 
selected, the corresponding attribute of the selected elements is changed to the new value.

Because the priority of the selected block has been changed to 100, it is displayed in front of the other elements now.

Let’s change the transparency of the block that is on top, to be able to see the other elements through it.

9. With Element Selection, select the block on top.

10. Click the Active Transparency icon in the Attributes group and set the value to 30.

11. Enter a data point to clear the selection.
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The block is transparent now.

If no transparency is displayed, you should check the view attributes for the current view.

12. Open the View Attributes dialog by clicking View Attributes, the first icon in the view control bar at the top of view 1 (or press Ctrl + B).

13. Ensure that the Transparency view attribute is enabled for view 1, otherwise the transparency is not displayed.

14. Close Element_Attributes.dgn.
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Controlling the Display of Designs
The exercises in this workbook show you how to view your designs, by using view controls and multiple view 
windows. You will also practice how to set the view attributes and control the level display.
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Zoom and pan using the view controls

Your design is displayed in a view window. That is where you draw. 
To manipulate the portion of the design that is displayed in a view window you can use the view controls. These view 
controls can be selected in the view control bar that is docked to the top of the view window.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Viewing_Designs.dgn from the \MSBasics\dgn\03 - Controlling the Display of Designs folder in the course 
dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Element Creation model by double-clicking it in the list.

5. Select the Window Area tool.

6. Enter two data points to define the area you want to zoom to.
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Just like with most MicroStation tools, you can use this tool multiple times, until you reset (click the right mouse button) or select another 
tool.

7. Select the Fit View tool to make the complete design visible again.

8. Try to zoom in and out using the Zoom In and Zoom Out tools in the view control bar.

9. To view a different part of the design without zooming in or out, click the Pan View tool and enter two data points: one to pick a point in the 
design and another to define the new location.

10. To rotate the view, click the Rotate View tool, ensure the method in the tool settings is set to 2 Points, and enter two data points to define 
the new horizontal direction.

11. To restore the design to its original orientation, make sure Rotate View is still active and set the method to Unrotated.

12. Try out the View Previous and View Next tools.

You can use these tools to undo the last view control action(s), or to redo a view control action after undoing it.

The Update View tool is provided to redraw the display when an operation leaves a view with an incomplete display.
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13. Fit the view.

You can use a view control even while drawing or manipulating an element. Let’s try that.

14. Select Place SmartLine on the Home tab in the Placement group.

15. Enter two data points not too far from each other to define the first segment of a line string. Do not reset!

16. Select Window Area.

The view control is immediately active and the drawing operation in progress is suspended.

17. Enter two data points to zoom in to the area where you are drawing the line string.

18. Then click the reset button (right mouse button).

Now you can continue the drawing operation from the point at which it was suspended.

19. Place another data point to define a second line segment.

20. Reset to complete.
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Zoom and pan using the mouse

Many of the zoom and pan actions can also be executed through the use of the mouse buttons and mouse wheel, 
sometimes in combination with a key on the keyboard. These are the most-used ones.

 Roll mouse wheel – To zoom in and out.

 Drag mouse wheel – To pan.

 Double-click mouse wheel – To fit the view.

 Shift + drag mouse wheel – To rotate the view dynamically.

 Alt + roll mouse wheel – To pan left or right.

1. Continue in Viewing_Designs.dgn, in the Element Creation model.

2. Try to zoom and pan using the mouse buttons and key combinations.
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Open multiple view windows

To view your design, you can open up to eight view windows. They allow you to view the design from multiple view 
points. It’s like viewing the active model with eight cameras and watching all displays on your screen at the same time, 
like a television director in the control room.

Each view window has its own view control bar, to control what is displayed in that view. A view control operates on the 
view window in which you select it.

1. Continue in Viewing_Designs.dgn, in the Element Creation model.

2. Open three more views by clicking the 2, 3, and 4 buttons in the Manage View Groups toolbox. This toolbox is by default displayed at the 
lower left of the application window.

Hint: If this toolbox is not displayed, press Ctrl + T (or select File > Settings > Tool Boxes) and in the Tool Boxes dialog turn on the 
Manage View Groups toolbox.

3. Arrange the views by selecting Tile on the View tab, in the Window group.

  



  
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Hint: You can also resize a view window manually by dragging one of its borders or corners. Or move a view window by dragging its title 
bar. To minimize unused screen area after resizing view windows select Arrange on the View tab, in the Window group.

When you select a view control from a particular view's view control bar, it automatically operates on that view.

4. In view 1, fit the view.

5. In view 2, first fit the view and then select Window Area in its view control bar and zoom in to the top of the map.

In view 3, you want to display the lake that is located in the center of the map. You will define this zoom area in view 1.

6. Select Window Area in the view control bar in view 3, because that is the view to which you want to apply the zoomed area.

7. Define the area to display by entering two data points in view 1.

The zoomed area is applied to view 3, because that’s where you activated the Window Area tool.
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8. Use the same method to display the bottom part of the map in view 4.

9. Click Save Settings in the Quick Access tool bar to save this view windows layout and the zoom areas in each view in the active DGN file.

Note that you are viewing only one design: the active model. When drawing or manipulating elements, you can simply switch between the 
different view windows to define points.

10. Select Place SmartLine and place the start point of the new line in view 2.

11. Move the pointer to view 4 and place the next vertex there.

Note that the line is displayed in all four views, of course, as they all display the same model. 

12. Place some more vertices in the other views and reset to complete.

13. Close all the views by clicking the Close button at the top right corner of each view (or drag over the 1, 2, 3, and 4 buttons in the Manage 
View Groups toolbox).

Note that closing all the view windows is not the same as closing the DGN file! You may close all the view windows (turn off all the 
cameras), but the file is still open. 
The title bar at the top of the MicroStation application window displays the name of the open file.

14. Drag over the 1, 2, 3, and 4 buttons in the View Groups toolbox to turn the four views on again.

Each view window’s title bar shows the name of the model that is displayed in that view window.
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Control the display by setting the view attributes

View windows have a number of attributes that determine:

 which elements are displayed (texts, dimensions, patterns, etc.) 

 how the model is displayed (with fill, transparency, a grid, a clip volume, a background image, etc.)

These view attributes can be adjusted for each view individually, in the View Attributes dialog.

1. Continue in Viewing_Designs.dgn, in the Element Creation model, with views 1 to 4 open.

Note that the lakes and rivers are filled in view 1, but not in the other views.

2. In view 3, click the View Attributes icon, the first icon in the view control bar, to open the View Attributes dialog (or press Ctrl + B).
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3. Note that the dialog is opened with the view number set to 3, so the view attributes for view 3 are displayed. If not, click in the title bar of 
view 3.

4. On the Presentation panel, enable the Fill view attribute.

The lakes, rivers, and parks are displayed with a fill now.

5. To apply the view attributes of the current view to all other open views, click Apply to open views at the top of the View Attributes dialog.

In view 2 and 4, the rivers are also displayed with a fill now.

6. Click in the title bar of view 1.

The view attributes of view 1 are displayed in the View Attributes dialog.

7. Turn off the Line Weights view attribute for view 1 to display all elements without a thickness.

8. Click in the title bar of view 3 and turn off the Text view attribute, to turn off the visibility of the texts in view 3.

9. Click in the title bar of view 2 and click Apply to open views, to display all views with the same view attributes as in view 2.

10. Click Save Settings in the Quick Access tool bar (or press Ctrl + F) to save the current layout, zoom areas, and view attributes of the four 
views with this model in the active DGN file.
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Hint: It’s also possible to display a different model in each view window, at least if the model is in the same DGN file. In the View 
Attributes dialog, expand the View Setup panel and behind Models select the model that you want to be displayed.
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Control the display by setting the level display

In addition to the view attributes, there is another option to control the display of a design: by turning levels on or off. 
Presuming that the elements in the design are drawn on the correct levels, as determined by your organization’s 
standards, this allows you to view (or print) exactly the information you want. 
Just as with the view attributes, the level display can be adjusted for each view individually, in the Level Display dialog.

1. Continue in Viewing_Designs.dgn, in the Element Creation model, with views 1 to 4 open.

2. Open the Level Display dialog by clicking the Level Display icon on the Home tab in the Primary group.

The title bar indicates for which view the level display settings are shown.
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3. Click in the title bar of view 1 to ensure that the level display settings for view 1 are displayed in the dialog.

The active level has a green background color and can not be turned off. You can change the active level by double-clicking on it.

4. In the level list, click the level named Boundary.

The yellow boundary in view 1 disappears.

5. Click the Name column’s heading (twice, if needed) to sort the levels by name, from A to Z.

The Used column contains a dot if there are elements on that level (in the active model).

6. Click the Used column’s heading to display all used levels at the top of the list.

7. Click the levels Arterials and Collectors to turn them off.

The black and magenta street lines become invisible in view 1, but are still displayed in the other views.

There is another – very easy – way to turn a level off: by selecting an element on that level.

8. Click in the title bar of view 3 to show the level display settings for view 3 in the Level Display dialog.
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9. Right-click on the level list and in the context menu select Off By Element.

10. In view 3, select one of the green filled areas that represent the parks.

All parks on that same level, the level Park - City, are turned off in view 3.

The tool is still active, so you can select more elements, if you like.

11. Select other elements on other levels, for example, the railway and the yellow-green shape that represents a cemetery.
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12. Scroll through the level list and note that the associated levels are indeed turned off.

13. To turn all levels in view 3 on again, right-click on the level list and select All On.

14. Right-click on the level list again and this time select All Except Element.

15. Again, select one of the green filled areas that represent the parks.

This time, all other levels are turned off, except the selected level Park - City.

16. Turn all levels on again in view 3.
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17. Click Apply To Open Views at the left top of the Level Display dialog to apply the level state of view 3 to all other open views.

Hint: You can use the view control View Previous to return to the previous level display state in a view.

18. Click View Previous in view 1 and note how the previous level display state is restored.

19. Do the same for view 3.

20. Close Viewing_Designs.dgn.
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Using AccuDraw and AccuSnap
By completing the exercises in this workbook you will learn how to draw accurately and efficiently by using the 
drawing aids AccuDraw and AccuSnap.
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Snap to points on elements with AccuSnap

AccuSnap is a drawing aid that helps you select precise locations on elements in a design, such as the end point of a 
line or the center of a circle. This operation is called snapping. Various snap modes help you to get the point you want.

 Double-click a snap mode icon – To set a snap mode as the default snap mode.

 Single-click a snap mode icon – To set a snap mode override for one operation only. Then MicroStation returns to 
the default snap mode.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open AccuSnap.dgn from the \MSBasics\dgn\04 - Using AccuDraw and AccuSnap\dgn\ folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. If the Snap Mode toolbox is not yet displayed on your screen, open it by selecting the Snap Mode icon on the Drawing Aids tab, in the 
Snaps group.

4. Ensure that AccuSnap is enabled by checking that the first icon Toggle AccuSnap is highlighted.
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Hint: If you do NOT want to automatically snap to the nearest snap point, you can turn AccuSnap off (or on) temporarily by holding the 
Ctrl + Shift keys pressed.

5. Zoom in to the upper four figures.

6. Complete the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

7. Select Place SmartLine on the Home tab in the Placement group, with the following tool settings:

8. In the Snap Mode toolbox, double-click the Key Point Snap icon to set it as the default snap.
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You will first create the rotated block within the block at the top. 

9. Move the pointer close enough to the point to which you wish to snap.

A bold, yellow X is displayed on the snap point.

10. Accept the snap point with a data point.

11. Complete the rotated block by snapping to the mid points on the other three sides of the block, using the Key Point snap (or the Mid Point 
snap).

12. To create the V-line in the same block, start at one of the corner points at the top using the Key Point snap.

13. To find the center of the block, click once on the Center Snap icon to override the default Key Point snap for only one operation.

14. Move the pointer to one of the sides of the outer block, to select the block of which you want to find the center.

Note that, although you point at the side of the block, the bold yellow X is displayed in the center point.
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15. Click on the side of the block to accept the center point.

The point is placed and MicroStation returns to the default snap mode: Key Point.

16. Snap to the other corner point at the top.

17. Reset to complete the V-line.

In the next figure, you have to create three lines: A, B, and C.

18. With Place SmartLine still active, single-click the Perpendicular Snap icon.

19. To create line A, snap to an arbitrary point on the oblique line.

MicroStation returns to the default snap mode: Key Point.

20. Move the pointer and notice that the new line is perpendicular to the oblique line.

21. Snap to the left end point of the lower horizontal line to define the end point of line A.

22. Reset to complete.

23. To create line B, single-click the Perpendicular Snap icon again.
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24. Snap to an arbitrary point on the upper horizontal line.

The location of vertical line B is arbitrary, as long as it starts and ends exactly on the two horizontal lines.

25. Single-click the Near Snap Point icon and snap to an arbitrary point on the lower horizontal line. 

26. Reset to complete.

MicroStation returns to the default snap mode: Key Point.

27. To create line C, snap to the right end point of the upper horizontal line.

28. Single-click the Intersect Snap icon and snap to the intersection of line B and the oblique line. 

29. Reset to complete.
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Use more snap modes

By default, not all snap modes are displayed in the Snap Mode toolbox. If you need additional snap modes, you can 
right-click the toolbox and display more snap mode icons.

The three Multi‐snap snap modes allow you to use multiple snap modes at the same time.

1. Continuing in AccuSnap.dgn, zoom in to the four figures at the bottom.

2. Complete the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

3. Use Place SmartLine and the default Key Point snap to create the crossing lines within the upper circle.
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4. To create the tangent lines double-click the Tangent Snap icon.

You will need this snap mode several times, that is why you set it as the default snap mode.

5. Snap to the larger circle and move the pointer to view the tangent line you are creating.

6. If you want to change the direction of the tangent line, move the pointer through the circle.

7. With the Tangent snap mode still active, snap to one of the sides of the smaller circle to create the desired tangent line.

8. Reset to complete.

9. Create the two other tangent lines between the circles.

To create the vertical tangent line, you will not use the Tangent snap, but the Key Point snap, together with AccuDraw.

10. Double-click the Key Point Snap icon to set it as the default snap mode.

11. With Place SmartLine, snap to the right quadrant point on the smaller circle to define the start point of the vertical line.

The AccuDraw compass displays in this start point.

12. Move the pointer upwards on the AccuDraw axis and press the Enter key to lock it to the axis.
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13. Snap to the top quadrant point on the larger circle to define the length of the vertical line.

14. Reset to complete.

Then you will create the two horizontal lines in the circles at the bottom.

15. Single-click the Intersect Snap icon and snap to the upper intersection point of the two circles.

16. Move the pointer to the left on the AccuDraw axis and press the Enter key to lock it to the axis.

17. Single-click the Near Snap Point icon and snap to the upper circle to define the end point of the line.

18. Reset to complete.

19. Repeat these steps to create the second horizontal line.

20. Close AccuSnap.dgn.
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Introduction to AccuDraw

AccuDraw is an intuitive drawing aid that helps you to define exact distances and angles while creating new elements or 
manipulating existing ones. In this exercise, you will first explore the behavior of AccuDraw.

1. Open AccuDraw.dgn.

2. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

3. Open the Introduction AccuDraw model by double-clicking it in the list. This model is empty.

4. Ensure AccuDraw is enabled by locating the AccuDraw dialog. 

5. If AccuDraw is not enabled, click the Toggle AccuDraw icon on the Drawing Aids tab, in the AccuDraw group.
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6. Undock the AccuDraw window and drag it into the view, so that it’s easier to see if AccuDraw has the input focus.

7. Select Place SmartLine with the following tool settings:

Segment Type: Lines

Vertex Type: Sharp

Join Elements: enabled

Rotate AccuDraw: enabled

Start in line mode: enabled

8. Enter a data point to define the start point of the line.

The AccuDraw compass appears, with its origin in the start point.

9. Slowly move the pointer around the compass and watch how the X and Y values in the AccuDraw window update to reflect the distance 
between the pointer’s location and the origin of the compass. 

A positive or negative value is displayed, depending on the location of the pointer.
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10. Move the pointer slowly toward the positive X axis (red tick).

Once you are within a certain locate tolerance, the line will move to, and stay on, the X-axis. This is called ‘indexing’.
Note that the Y value is set to 0 now.

11. Move the pointer toward the positive Y axis (green tick) until it indexes to that axis. 

Now the X value is set to 0. The Y value reflects the distance to the origin of the compass.

So when AccuDraw is in its rectangular mode, the fields in the AccuDraw window reflect the pointer location as an X and a Y distance to 
the origin of the compass.

12. Press the M key on your keyboard to change the AccuDraw compass to its polar mode, indicated by a circular compass. 

In polar mode, the fields in the AccuDraw window reflect the pointer location as a distance and an angle to the origin of the compass.

13. Again, slowly move the pointer around the compass and watch how the distance and angle values in the AccuDraw window update to 
reflect the location of the pointer relative to the compass’ origin. Note that the pointer can still index to the axes.

14. Press the M key again to change the AccuDraw compass to its rectangular mode (square compass). 

While drawing new elements or manipulating existing ones, you can switch between these two AccuDraw modes at any moment and 
select the mode that is most convenient.

15. Reset to stop drawing.
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Draw accurately using AccuDraw

AccuDraw is designed to make it as easy as possible for you to define points accurately when creating or modifying an 
element. While drawing, AccuDraw evaluates the location of the pointer, which drives its intuitive behavior.

1. Continuing in AccuDraw.dgn, open the Learning AccuDraw model.

2. Ensure that AccuDraw is enabled and in rectangular mode.

When active, AccuDraw tries to anticipate your intent by reading your pointer movement. 
So when using AccuDraw to define a point, rule 1 is: move the pointer in the direction in which you wish to draw.

The next step is to enter the desired values for the distances and/or angle into the AccuDraw window. But – rule 2! – do that without 
clicking in the input fields in the AccuDraw window! Because, if you move the pointer to the AccuDraw window, the information about the 
direction in which you want to draw gets lost!

That is why the AccuDraw window's input focus automatically adjusts, based on the general direction of the pointer movement. The best 
way to experience and learn to follow that behavior is by creating a simple figure, such as the following object.

You will start at the lower left corner and draw in a counterclockwise direction.

3. Select Place SmartLine and enter a data point anywhere to start.

This is the first vertex of the element and the AccuDraw compass appears at the data point location.

4. Move the pointer to the right and keep it indexed to the X axis.
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Note that the X field has the input focus. When you type in a value now, it will automatically appear in that field.

5. Without moving the pointer into the AccuDraw window, type 2000 on the keyboard. 

You don’t have to delete the previous value! Just type the new value and the old value will be replaced.

6. Enter a data point to accept the value. 

Note that the compass moves to the last data point.

7. Move the pointer upward and index to the Y-axis.

8. Type 800 and accept with a data point.

Hint: If something goes wrong, you can press Ctrl + Z (or select Edit > Undo) to undo the last segment and continue from the previous 
point.

Next, you will draw the oblique segment.
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9. Move the pointer in the direction you wish to draw, like in the image below.

As a rule, the field with the largest value has the input focus, in this image the Y field. That is because the pointer is closer to the Y axis. 
So generally, you type that value first, then press the Tab key to switch to the other field, and type the other value.

If you prefer to enter the value in the other field first, do NOT click in that field! Just move the pointer a bit closer to the other axis and the 
input focus will change accordingly.

10. Ensure the Y field has the input focus. If needed, move the pointer a bit closer to the horizontal axis.

Don’t worry if this is the X or the Y direction. AccuDraw will take care of that. Just make sure that the pointer is in the right direction.

11. Type 1000 and press the Tab key to switch to the other field (or move the pointer a bit).

The Y field is locked now and the pointer’s movement is constrained.

12. Type 500 in the other field.

Both fields are now locked.

Hint: If you have to correct the input, you can press the X key or the Y key on your keyboard to unlock the field.

13. Accept the new point with a data point.
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The compass is rotated in the direction of the last segment.

14. To rotate the compass to align with the view axis, press the V key on the keyboard (V = View Rotation).

This is a so-called ‘shortcut key-in’, a specific AccuDraw command. AccuDraw shortcut key-ins only work when the focus is in the 
AccuDraw window. So if needed, press F11 or click in the AccuDraw window first.

The next point should be exactly above the start point. Let’s use an easy trick.

15. Move the pointer to the left and index to the horizontal axis.

16. Press the Enter key to lock the pointer to the axis.

The Y field is locked to 0 and the pointer’s movement is constrained.

17. With the Key Point snap mode active, snap to the start point of the figure to define the distance of the horizontal line.

18. Close the figure by snapping to the start point again.
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AccuDraw challenge

In this exercise, you will create several figures to practice using AccuDraw in rectangular and in polar mode.

1. Continuing in AccuDraw.dgn, open the AccuDraw Challenge model,

2. Create these figures using the Place SmartLine or Place Block tool. Decide for yourself if you want to use AccuDraw in rectangular or in 
polar mode.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

You will start with the first figure at the lower left point.

3. Select Place SmartLine and enter a data point anywhere to start.

4. Ensure the rectangular AccuDraw compass is displayed. If not, press the M key.

5. Move the pointer in the direction you wish to draw.
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6. Move the pointer a bit closer to the Y axis to ensure the input focus is in the Y field and type 18.

7. Press the Tab key (or move the pointer closer to the X axis) and type 15.

8. Accept with a data point to create the first segment.

The next segment is perpendicular to the first segment.

9. Index the pointer to the negative Y axis and press Enter to lock the X value to 0.

10. Type 20 and accept.

To create the horizontal segment, you have to rotate the AccuDraw compass.

11. With the focus in the AccuDraw window, press the V key.

12. Move the pointer to the right and index to the axis.

13. Type 22 and accept.

14. Move the pointer downwards and press Enter to lock it to the axis

15. Snap to the start point of the figure to define the length of the last segment.

16. Reset to complete.
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To create the equilateral triangle you will need the polar mode. You will start at the lower left corner and draw the 60° line segment first.

17. With Place SmartLine, enter a data point anywhere to start.

18. Press the M key to switch to AccuDraw’s polar mode.

19. To define the line segment at 60°, first move the pointer in the desired direction, as usual.

20. With the input focus in the Distance field, type 30.

21. Press Tab to switch the focus to the Angle field.

22. Type 60 and accept with a data point.

23. Rotate the AccuDraw compass by pressing the V key.
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24. Move the pointer in the desired direction.

25. With the input focus in the Angle field, type ‐60.

Note the minus sign! When setting an angle in AccuDraw, you have to add the minus sign yourself.

26. With the Angle field locked, move the pointer along the proposed line until a small perpendicular line is displayed.

This line indicates the last used distance, so the length of the previous segment: 30.

27. While indexing to the small line, enter a data point.

28. Close the triangle by snapping to the start point.

Next, you will create the block.

29. Select Place Block and enter a data point anywhere to start.

Note that with Place Block, AccuDraw automatically toggles to its rectangular mode.

30. Move the pointer in the desired direction and, moving the pointer closer to the X axis, type 31.7 for the X value.

31. Press Tab to switch to the Y field, type 17.9, and accept with a data point.
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To create the next triangle, use Place SmartLine and the rectangular mode.

32. The easiest way to create this triangle is to start at the top and create the vertical and horizontal segments first. Then you can create the 
oblique segment by snapping to the start point.
When you start at the lower left corner, you can define the oblique segment by entering an X and a Y value in the AccuDraw window.

For the next triangle, you need the rectangular as well as the polar mode.

33. With Place SmartLine, enter a data point anywhere to define the left vertex.

34. To define the bottom vertex, ensure AccuDraw is in the rectangular mode and, with the pointer pointing in the right direction, enter the X 
and Y values.

35. To define the right top vertex, rotate the compass by pressing the V key and switch to the polar mode. 
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36. Move the pointer in the right direction, type 31 for the distance, press Tab, type 75 for the angle, and accept with a data point.

37. Close the shape by snapping to the start point.
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Use AccuDraw shortcuts

AccuDraw includes a variety of single and double character commands known as shortcut key-ins. By pressing the 
appropriate key while the focus is in the AccuDraw window, you can direct AccuDraw to perform a specific task.
Here are several much-used shortcuts:

 M – Toggles between rectangular and polar mode (Change Mode).

 V – Rotates the compass to align with the view axis (View Rotation).

 Enter – Indexes to the closest axis and locks the opposite field value (Smart Lock).

 X / Y – Locks or unlocks the X or Y value when in rectangular mode.

 D / A – Locks or unlocks the Distance or Angle value when in polar mode.

 O – Moves the compass to the current pointer position or snap point (Set Origin). 

 RQ – Rotates the compass to a user defined angle (Rotate Quick).

 RE – Rotates the compass to match the orientation of a selected element (Rotate to Element).

 I – Activates the Intersect snap mode (Intersect Snap).

 C – Activates the Center snap mode (Center Snap).

 ? – Opens a window showing a list of all AccuDraw shortcuts.

1. Continuing in AccuDraw.dgn, open the AccuDraw Shortcuts model.

You will create the following elements.
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Let’s start with the lines in the left figure. Both lines have the same arbitrary length.

2. With Place SmartLine, enter a data point to define the start point at the bottom.

3. Move the pointer upwards and index to the Y axis.

4. Define the length graphically by entering a data point.

5. Move the pointer to the right until a small line perpendicular to the horizontal axis appears.

This line indicates the last used distance, so the length of the previous segment.

6. While indexing to the axis and to the perpendicular line, enter a data point.

7. Reset to complete.
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8. Select Place Circle with the following tool settings:

Method: Center

Diameter / Radius: disabled

To define the center point of the circle at the right location, without using a construction line, you will use the AccuDraw shortcut key-in O.

9. Ensure the AccuDraw window has the input focus by:

 Clicking in the titlebar of the AccuDraw window. 

 Pressing the F11 key (if you are using the default function key menu delivered with MicroStation).

10. Move the pointer to the end point of the horizontal line until you see the yellow x. Do not enter a data point to accept the snap point!

11. Press the O (for Origin) key to recall the AccuDraw compass in this location.

12. Move the pointer downwards and press Enter to lock it to the axis.

13. With the Key Point snap mode active, snap to the start point of the vertical line to define the center of the circle.

14. Next, enter a data point to define the radius of the circle graphically.
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For the second figure, you will create an oblique line first. Then you will place a rotated block at the same angle and at a certain distance 
from the end point of the line.

15. Select Place SmartLine and place a line at any angle. The length of the line is not important.

16. Select the Place Block tool (Home tab > Placement group) with the following tool settings:

Method: Orthogonal

Area: Solid

Fill Type: None

17. Move the pointer to the upper right end of the line until you see the yellow x. Do not enter a data point to accept!

18. With focus in the AccuDraw window, press O (for Origin).
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The AccuDraw compass is placed at the snap point.

19. Press RQ (for Rotate Quick) to rotate the compass.

Note the prompt in the status bar: the Rotate Quick shortcut asks you to define the X-axis. 

20. Move the pointer towards the other end of the line, snap to the end point, and accept with a data point.

The compass rotates to the direction of the line.

Note that you have returned to the Place Block tool. You are now ready to define the first corner point of the block.

21. Move the pointer upwards and towards the right and index to the negative X-axis.

22. Press the Enter key to lock the Y value to zero.

This is not mandatory. If you do not press Enter, you have to be more careful to accept on the axis.

23. Type 1000 and accept with a data point.

Note that you do not have to worry about adding a minus sign or not. Because the pointer indicates the direction along the negative X 
axis, AccuDraw adds a minus sign automatically. So again, the location of the pointer is very important!
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You have now placed the first corner point of the block. Note that it is rotated, even though the method was set to Orthogonal.

24. Move the pointer along the X axis (to move the input focus to the X field) and type a value of 750.

25. Then move the pointer along the Y axis and type a value of 1000.

26. Enter a data point to create the block.

For the third figure, you will draw an oval shaped element around a rectangle. The only information you have is the minimum clearance 
distance from the rectangle.

27. Select Place Block and place a vertical block of any size.

The first vertex of the oval shape will be offset from the top right corner of the block. 

28. Select Place SmartLine with the following tool settings:

Segment Type: Lines

Vertex Type: Sharp

Join Elements: enabled
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Rotate AccuDraw: enabled

Start in line mode: enabled

29. With the Key Point snap mode active, move the pointer to the top right corner until you see the yellow x. Do not enter a data point to 
accept!

30. With focus in the AccuDraw window, press O (for Origin) to recall the AccuDraw compass in this snap point.

31. Move the pointer to the right, index along the X-axis, and type a distance that is appropriate with regard to the block you created.

32. Enter a data point to place the first vertex of the new element.

33. Move the pointer downward and press Enter to lock it to the axis.

The X value is locked to zero.

34. Snap to the lower right corner of the block to define the length of the line segment and accept with a data point.

35. In the tool settings, change the segment type from Lines to Arcs.

The prompt asks you to define the location of the arc center.
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36. Snap to the midpoint of the block’s lower edge and accept with a data point.

Next, you need to define the sweep angle of the arc. 

37. Move the pointer clockwise and sweep through 180 degrees. Enter a data point to accept the sweep.

38. In the tool settings, change the segment type to Lines.

39. Move the pointer upward and press Enter to lock it to the axis.

40. Snap to the upper left corner of the block to define the length of the line segment and accept with a data point.
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41. In the tool settings, change the segment type to Arcs.

42. To define the location of the arc center, snap to the midpoint of the top edge of the rectangle and accept with a data point.

43. Move the pointer clockwise to draw the 180 degree arc and enter a data point to complete the oval shape.

44. Close AccuDraw.dgn.
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Creating Drawing Elements
By completing the exercises in this workbook you can practice how to create new drawing elements efficiently 
and accurately using tools such as Place SmartLine, Place Circle, Create Region, and others.
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Place SmartLine

With Place SmartLine, you can place a line, line string, shape, arc, or circle, or a combination of these as a complex 
chain or complex shape. You can find the Place SmartLine tool on the Home tab in the Placement group.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Learning.dgn from the \MSBasics\dgn\05 - Creating Drawing Elements folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the AccuDraw model by double-clicking it in the list.
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5. Create these figures using the Place SmartLine tool. Use AccuDraw to define the exact lengths and angles, without creating any 
construction lines.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

Let’s start with the first figure, the church.

6. Select Place SmartLine with the following tool settings:
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Segment: Lines

Vertex: Sharp

Join Elements: enabled

Rotate AccuDraw: enabled

Start in line mode: enabled

7. Enter a data point to define the lower left corner of the figure and use AccuDraw to define a vertical line with a length of 41 units.

8. If a rectangular AccuDraw compass is displayed, ensure that the AccuDraw dialog has the input focus and press M (Change Mode) to 
switch to the polar AccuDraw compass.

9. With the focus in the AccuDraw dialog, press the V (View Rotation) key to align the compass with the view axes.

The red tick, indicating AccuDraw’s X axis, should be horizontal now.

10. Move the pointer in the proposed direction, key-in 15 for the distance, press Tab, key-in 70 for the angle, and accept with a data point.

11. Press the V key again to align the compass with the view axes.

12. Move the pointer in the proposed direction until a perpendicular tick appears.

This tick indicates the last used distance.

13. While the tick is displayed, press the D key to lock the distance to the previous distance (15).

14. Press Tab to switch to the Angle field, key-in ‐70 for the angle (note the minus sign!), and accept with a data point.

Hint: If you place an incorrect vertex, you can press Ctrl + Z or select Undo once (or multiple times, if needed) to undo the last 
segment(s). Then resume entering points. Do not reset the Place SmartLine tool first!

15. Press M to switch to the rectangular AccuDraw compass and press the V key to align the compass with the view axes.

16. Use AccuDraw to define the next vertical segment and horizontal segment.
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17. Switch to the polar AccuDraw compass to define the oblique segment.

18. Move the pointer in the proposed direction, key-in 13 for the distance, press Tab, key-in ‐40 for the angle, and accept with a data point.

19. Switch to the rectangular AccuDraw compass and press the V key to rotate the compass.

20. Move the pointer downwards and press Enter to lock the pointer to the AccuDraw axis.

21. Snap to the start point of the figure to define the segment length.

22. Snap to the start point again to close the figure.

A shape is created. Let’s check this.

23. Move the pointer to one of the snap points on the figure, without clicking.

The complete figure highlights and the tooltip indicates that it is a shape. If not, you have probably interrupted the Place SmartLine tool 
while drawing. That’s no problem; in one of the last exercises in this workbook you will learn how to tie the segments together into one 
element.

Let’s create the second figure, the P.

24. Select Place SmartLine with the following tool settings:

Segment: Lines

Vertex: Sharp

Join Elements: enabled
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Rotate AccuDraw: enabled

Start in line mode: enabled

25. Enter a data point to define the lower left corner of the figure and use AccuDraw to define a vertical segment with a length of 36 units and 
a horizontal segment of 14 units.

26. In the tool settings, change Segment to Arcs.

27. Move the pointer downwards and define the center of the arc 10 units below the last point.

28. Move the pointer around the center point to display the desired arc and enter a data point on the downward AccuDraw axis.

29. Change Segment to Lines again.

30. Complete the outline of the figure by drawing the last three segments.

Because this figure contains an arc, it is a complex shape instead of a shape.

31. To define the start point of the inside of the P figure, with Place SmartLine active, move the pointer to the snap point at the inside corner of 
the outline, but do not click there! Just make sure the yellow x is displayed in the snap point.

32. Check if the AccuDraw dialog has the input focus. If not, press the F11 key to move the focus there.

33. Then press the O key (Set Origin), to display the AccuDraw compass in that snap point.

34. Move the pointer upwards, key-in 7 to define the distance, and accept with a data point.

35. Create a vertical segment and a horizontal segment, both with a length of 6 units.
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36. In the tool settings, change Segment to Arcs.

37. Move the pointer downwards and define the center of the arc 3 units below the last point.

38. Move the pointer around the center point to display the desired arc and enter a data point on the downward AccuDraw axis.

39. Change Segment to Lines again.

40. Close the figure by snapping to the start point.

Again a complex shape is created.

To create the third figure, the profile, you will use the Vertex tool setting.

41. Select Place SmartLine with the following tool settings:

Segment: Lines

Vertex: Sharp

Join Elements: enabled

Rotate AccuDraw: enabled

Start in line mode: enabled

42. Enter a data point to define the lower left corner of the figure and use AccuDraw to define a vertical segment with a length of 30 units and 
a horizontal segment of 5 units.

Currently, you’re creating sharp corners.
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43. To change the vertex type of the last vertex, in the tool settings change Vertex to Rounded and set Radius to 2.5.

44. Then move the pointer downwards and define the length of the next segment: 25.

45. Continue with a horizontal segment of 25 units and a vertical segment of 5 units.

The vertices are rounded now. The vertex type of the last vertex, the lower right corner, should be sharp again.

46. In the tool settings, change Vertex to Sharp.

47. Close the figure by snapping to the start point.

A complex shape is created.

Hint: You can change the type of a vertex afterwards with the Modify Element tool. Just snap to the vertex, change the Vertex tool 
setting (and the rounding radius or the chamfer offset), and snap to the original point again.

48. Do not delete the figures you created, as you will use them later for other exercises in this practice workbook.
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Place Block

With Place Block, you can place an orthogonal or a rotated block (rectangular shape). You can find the Place Block tool 
on the Home tab in the Placement group.

1. Continue in Learning.dgn, in the AccuDraw model.

2. Create these figures using the Place Block tool. Use AccuDraw to define the exact sizes and angles.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

Let’s start with the square.
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3. Select Place Block with the following tool settings:

Method: Orthogonal

Area: Solid

Fill Type: None

4. Enter a data point to define the lower left corner of the square.

5. Move the pointer to the right and a bit upwards, and key-in 25 to define the width.

6. Move the pointer upwards, key-in 25 again to define the height, and accept with a data point.

Then you will create the rotated block.

7. Select Place Block with the following tool settings:

Method: Rotated

Area: Solid

Fill Type: None

8. Enter a data point to define the lower left corner of the block.

9. If a rectangular AccuDraw compass is displayed, press M to switch to the polar AccuDraw compass.

10. Move the pointer in the direction that defines the base of the block, key-in 40 to define the width, press Tab, key-in 24 for the angle, and 
accept with a data point.

11. Move the pointer upwards, key-in 21 to define the height, and accept with a data point.
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Place Circle

The Place Circle tool is used to create circles. You can find the Place Circle tool on the Home tab in the Placement 
group.

There are three methods to create a circle:

 Center – Position a circle by center.

 Edge – Create a circle by defining three points on its circumference.

 Diameter – Position a circle by defining the diameter's end points.

1. Continue in Learning.dgn, in the AccuDraw model.

2. Create these figures using the Place Circle tool. If lines or shapes are part of the figures, create those first and then the circles. Use 
AccuDraw and snaps to define the exact sizes.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. Create the first circle using the Center method and ensure the Diameter/Radius option is disabled.

When you use the Center method, the AccuDraw compass is displayed in the center point and you can easily key-in the radius.

4. For the second circle, the Diameter method is the most convenient.

With this method, the AccuDraw compass appears in the diameter’s end point, allowing you to key-in the diameter.

5. For the third figure create the triangle first, using Place SmartLine.

6. To create the circle within it, select Place Circle with the Edge method.

All three points on the new circle’s edge should be tangent to the sides of the triangle.

7. Double-click the Tangent Snap icon in the Snap Mode toolbox (Drawing Aids tab > Snaps group > Snap Mode), to set the active snap 
mode.
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8. Then define three points by snapping to each side of the triangle.

9. To create the fourth figure, first create the largest circle using the Diameter method.

10. Double-click the Keypoint Snap icon and create the medium-sized circles by snapping to the keypoints on the largest circle, still using the 
Diameter method.

11. You can create the two smallest circles the same way you created the tangent circle in the triangle: using the Edge method and the 
Tangent snap mode.

12. For the last figure, first draw an oblique line using Place SmartLine.

13. To create the first circle select Place Circle with the Center or the Diameter method.

14. With the Tangent snap mode still active, snap to the line.

When you move the mouse, the new circle will roll along the line.

15. Define the location and the size of the circle graphically by entering a data point. (Or enable the Diameter/Radius option and set the 
diameter or radius in advance.)

16. Create the second circle using the Edge method.

17. With the Tangent snap mode still active, snap to the existing line and circle, and define the third point graphically by entering a data point.
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18. Accept with a data point. (Or press the Alt key and move the pointer a bit to toggle between the different tangent circles that can be 
created, and then accept.)
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Place Arc

With the Place Arc tool you can create circular arcs. You can find the Place Arc tool on the Home tab in the Placement 
group.
Arcs can be placed clockwise or counterclockwise and there are several methods to be used for constructing the arc.

1. Continue in Learning.dgn, in the AccuDraw model.

2. Create these figures using the Place Arc tool. Create the lines first and then the arcs. Use AccuDraw and snaps to define the exact sizes.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

3. To create the first figure, start with placing the horizontal line using Place SmartLine.

4. Make sure the Keypoint snap is set as the active snap mode.

5. To start the vertical line exactly 15 units above the mid point of the first line, move the pointer to the snap point at the middle of the 
horizontal line, but do not click there! Just make sure the yellow x is displayed in the snap point.

6. Make sure that the AccuDraw dialog has the input focus. If not, press the F11 key to move the focus there.

7. Then press the O key (Set Origin), to display the AccuDraw compass in the snap point.
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8. To define the start point of the new line, move the pointer upwards, key-in 15 to define the distance, and accept with a data point.

9. Move the pointer downwards, key-in 30, accept with a data point, and reset.

10. Select Place Arc with the method Start, Mid, End and all the other options disabled.

11. Define the start point by snapping to the top end of the cross, then snap to the left end or the bottom end to define a point on the arc, and 
complete the arc by snapping to the right end of the cross.

12. For the second figure, create the lines first.

13. To create the inner arc, select Place Arc with the following tool settings:

Method: Start, Center

Radius: enabled + set to 30

Length: disabled

Start Angle: enabled + set to 270

Sweep Angle: enabled + set to 90

Direction: enabled + set to CCW (counterclockwise)
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14. The arc is defined now and you can place it by snapping to the lower left end point. Then reset.

15. To create the outer arc, use the method Start, Mid, End, disable all the other options, and snap to the three vertices of the line string.

16. After placing the lines for the third figure, you can create the arc by using the method Start, Center and disabling all other options.

17. Then snap to the upper left end (start point), the corner of the lines (center point), and the lower right end (end point).
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Drop Element / Create Complex Chain / Create Complex Shape

Complex chains and complex shapes are complex elements. A complex element is a grouping of multiple elements that 
is manipulated as a single entity. (Cells are also complex elements.)

Complex chains and complex shapes can be created with the Place SmartLine tool. 
To create complex chains and complex shapes (and line strings and shapes) from existing elements, you can use the 
Create Complex Chain or Create Complex Shape tool in the Groups group on the Home tab.

To convert a complex element (or a line string or shape) into its component elements so they can be manipulated 
individually, you can use the Drop Element tool in the Groups group.

1. Continuing in Learning.dgn, in the AccuDraw model, zoom to the three figures you created in the first exercise.

2. Select the Element Selection tool in the Selection group on the Home tab.

3. Right-press on the first figure, the church, and in the context menu select Properties.
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This opens the Properties dialog, with information about the selected element.

This first figure is (probably) a shape.

4. With the Element Selection tool still active and the Properties dialog open, select the second figure, the P.

This one is a complex shape.

5. In the Properties dialog, expand Complex Shape.

Note that this complex shape is composed of a line string and an arc.
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6. Deselect the element.

You will convert both figures to their component elements.

7. Select Drop Element in the Groups group and ensure that the options Complex and Line Strings/Shapes are enabled.

8. Select the first figure, which is a shape.

The shape is dropped to separate lines.

9. Delete the base line of the church.

10. Select Drop Element again and this time select the outline of the P figure.

This complex shape is dropped to a line string and an arc.

11. Select the line string once again, to drop it to individual lines.

Next, you will convert the individual elements into one (complex) element again. Let’s start with the – now open – church figure.
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12. Select the Create Complex Chain tool and set the following:

Method: Automatic

Max Gap: 0.001

Simplify geometry: enabled

13. Identify the first line of the dropped church figure and accept with a data point.

The other connected elements are automatically selected.

14. Accept to complete the creation of the new element.

Because the Simplify geometry tool setting was enabled and because no arcs are included, a line string is created instead of a complex 
chain.

Let’s continue with the P figure, which is a closed figure.

15. Select the Create Complex Shape tool and set the following:

Method: Automatic

Max Gap: 0.001
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Simplify geometry: enabled

16. Identify one of the elements of the dropped P figure and accept with a data point.

The other connected elements are automatically included.

17. Accept to complete the creation of the new complex shape.

Because arcs are included, a complex shape is created.

Hint: To be able to copy parts of an element parallel, you don’t have to drop the element! The Move/Copy Parallel tool has options to 
move or copy parallel a segment or a portion of an element.
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Create Region

With the Create Region tool, you can create a complex shape from existing elements. The new element can be 
associated with the original elements. You can find this tool in the Groups group on the Home tab.

1. Continuing in Learning.dgn, open the Create Region model.

2. Create these new filled elements from the existing (red) elements using the Create Region tool.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

First, you will create three filled shapes from the two blocks on the left.

3. Select Create Region and set the following:
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Method: Intersection

Fill Type: Opaque

Fill Color: 2

Keep Original: enabled

Associative Region Boundary: enabled

4. Select each block with a data point and accept with another data point.

A new element is created from the intersection of both blocks.

5. Use the Difference method and select different colors to create new filled elements for the remaining regions defined by the two blocks.

The region in the second figure is surrounded by lines, not by closed elements. So you can not use the Intersection, Union, or Difference 
methods now.

6. Select Create Region, choose another color, and this time select the Flood method.

7. Click within the region defined by the four lines and accept with a data point.

In the third figure, the block and the text should be kept free from the new filled element.

8. Select Create Region with the Flood method and choose another color.

9. In the tool settings, enable the Locate Interior Shapes button and the Locate Interior Text button, and set the Text Margin to 0.4.
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10. Then click within the region and accept with a data point.

In the figure on the right, the bottom half of the circle should be filled, by defining one new element. But the two blue lines are in the way! 
Solution: prior to using the Create Region tool, first select the elements that should be taken into account when the boundary of the new 
element is being generated.

11. So, with the Element Selection tool, first select the circle and the red line.

12. Then select Create Region with the Flood method and choose another color.

13. Click in the bottom half of the circle and accept with a data point.

The complete lower half of the circle is covered by the new filled element, disregarding the blue lines.

14. Clear the selection set.

Hint: So by selecting elements in advance, you can control which elements MicroStation should use to define the boundary of the new 
element, when using the Flood method.

Note that, if the tool setting Associative Region Boundary is enabled, the newly created element retains association with the original 
elements used to create it. So if one of the original elements is modified, then the new element updates to reflect the modification.

15. Try this out by moving or modifying some of the original red elements.
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Selecting Elements
This workbook contains exercises to practice how to select elements, graphically as well as by attributes, using 
the Element Selection tool or a fence.
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Select elements with Element Selection

The Element Selection tool can be used to select multiple elements for modification or manipulation. The collection of 
selected elements is called a selection set. You can find the Element Selection tool on the Home tab in the Selection 
group.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Selecting_Elements.dgn from the \MSBasics\dgn\06 - Selecting Elements folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Array Elements model by double-clicking it in the list.
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5. Select the Element Selection tool on the Home tab in the Selection group and set the following:

Method: Individual

Mode: New

6. While holding the Ctrl key down, select some individual elements by clicking on them.

7. Note that the number of elements in the selection set is displayed in the status bar.

8. Keep holding the Ctrl key down and click on some already selected elements to deselect them.

9. Release the Ctrl key and click somewhere in the design where there is no element.

This clears the selection set.

10. Without changing the tool settings, drag a selection rectangle from left to right around some elements.

All elements that are completely inside the selection rectangle are selected.

11. Clear the selection set.

12. Then drag about the same selection rectangle, but this time from right to left.
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Now, also the elements that are partly within the selection rectangle are selected (overlap).

Hint: By tapping the Shift key while dragging you can toggle between an inside and an overlap selection.

13. Clear the selection set.

So without having to change the tool settings, you can select and deselect elements in various ways: individually or by rectangle.

To select elements by line, shape, or circle you have to select another method in the tool settings.

14. Try out these selection methods. When holding the Ctrl key down, you can combine different selection methods, or deselect elements.

If you, by accident, clear a selection set, you can easily restore it.

15. Select some elements and then clear the selection set (or make another selection).
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16. Right-press somewhere in the view (keep the right mouse button pressed a little bit longer) and in the context menu select Select 
Previous.

The previous selection set is restored.
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Manipulate multiple elements

If you want to use a manipulation tool, such as Copy or Move, on multiple elements, you can:

 Select the elements in advance, using the Element Selection tool.

 Select the elements after activating the manipulation tool, by dragging a selection rectangle around them.

1. Continue in Selecting_Elements.dgn, in the Array Elements model.

2. Select some elements with the Element Selection tool.

3. Select the Copy tool on the Home tab in the Manipulate group.

4. Snap to a point on one of the selected elements and copy the elements to another location. 

5. Reset to complete.

Note that the Element Selection tool is automatically activated again. This makes it easier for you to complete the operation by clearing 
the selection set.

6. Click somewhere in the view to clear the selection set.

Let’s try out the other method now.

7. Select Copy and drag a selection rectangle around some elements.

Just as with the Element Selection tool you can drag from left to right (inside) or from right to left (overlap).

8. Snap to a point on one of the selected elements and copy the elements to another location. 

9. Reset to complete.

Note that this time the Copy tool remains active and no selection set is active.
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Select elements with a fence

Another method to select elements is by using a fence. Compared to the Element Selection, a fence has two additional 
capabilities.

 It can be used as a void to exclude elements inside (or overlapping) the fence boundary.

 It can clip elements that cross the fence boundary, so that only the parts inside (or outside) the fence boundary are 
selected.

A fence can be saved as a named boundary in the DGN file, for later use.

1. Continuing in Selecting_Elements.dgn, in the Array Elements model, make sure that no elements are selected.

2. Select Place Fence on the Home tab in the Selection group.

3. In the tool settings, set the following:

Fence Type: Block

Fence Mode: Inside

4. Place a rectangular fence that crosses several elements.

The fence is displayed as a transparent green rectangle.



Copyright © 2016 Bentley Systems, Incorporated 8DO NOT DISTRIBUTE - Printing for student use is permitted

5. Change the Fence Mode tool setting to Overlap and then to Clip, and note how the fence boundary changes from a solid line to a dashed 
or dashdot line.

6. Change the Fence Mode tool setting to Void‐Clip.

The fence is displayed in transparent red now, warning you that all elements outside the fence will be processed.

7. Select the Copy tool on the Home tab in the Manipulate group.

Note that the Use Fence tool setting is enabled automatically when a fence is present.

8. Snap to a point on one of the elements and copy the elements to another location. 

9. Reset to complete.
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10. To remove the fence click the Place Fence icon again.

All elements outside the fence and the outside parts of the elements overlapping the fence have been copied.

You can draw different types of fences: rectangular, polygonal, or circular. Or you can create a fence from an existing element, from a 
view, from the contents of the model, or from the area enclosed by a set of elements.

To delete (parts of) elements defined by a fence, you have to use the Delete Fence Contents tool instead of the Delete Element tool.

11. Place a circular fence over some elements and set the fence mode to Clip.
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Hint: If you want to snap to elements while placing a fence, hold the Ctrl + Shift keys down.

12. Select Delete Fence Contents in the Fence tools.

13. Accept the fence contents with a data point.

14. Click Place Fence again to remove the fence.

The elements and parts of the elements that are inside the fence have been deleted.
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Note: The clipped shapes have been closed again. That’s because the user preference Optimized Fence Clipping is enabled. You can 
find this setting on the backstage: click the File tab, select Settings > User > Preferences, and look in the category Operation.
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Select elements by attributes with Element Selection

In addition to selecting elements graphically, the Element Selection tool also allows you to select elements based on 
their attributes, for example, by color, by level, or by text style.

1. Continuing in Selecting_Elements.dgn, open the Element Creation model.

2. Select Element Selection with the following tool settings:

Method: Individual

Mode: New

3. Expand the tool settings by clicking the small downward arrow.
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4. Move the pointer over the tab headers to view on which attributes you can filter elements: element type, element class, element template, 
level, color, line style, and line weight.

You will select all elements on the levels Collectors and Arteriors, and change their color to 1 (blue).

5. Open the Level tab.

6. In the level list, click on the level Collectors.

The level name moves to the top of the list and is marked with a dot, and the 454 elements on this level are selected.

7. Click on the level Arterials too.

The elements on this level are also selected and highlighted.

8. On the Home tab in the Attributes group, click the Active Color icon and select color number 1.

This is a fast method to change the color of the selected elements.

9. Clear the selection set by clicking somewhere in the view.

Next, you will select all texts and text nodes and see if they have any text styles applied. The Text Style tab is not open by default, so let’s 
open it first.
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10. Right-click on one of the tab headers and enable the Text Style tab.

11. Open the Element Type tab and select the Text type as well as the Text Node type.

Both element types are moved to the top of the list and all text and text nodes (260) in the design are selected.

12. Open the Text Style tab and note that no text style is highlighted, so no text styles are applied to these elements.
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13. Open the Level tab.

It shows that the selected text elements are on eight different levels.

You will filter all texts and text nodes with color 6 (orange) and move them to the level text.

14. Open the Color tab.

To remove elements with specific attribute values from the current selection set, you simply have to deselect the not-wanted attribute 
values from the highlighted list at the top.
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15. Remove all colors, except for color 6 (orange), from the highlighted list, just by clicking on them.

Note that only 200 (instead of 260) elements are left in the selection set.

16. In the Attributes toolbox, click the Active Level icon and select the level text.

The selected text elements are moved to the level text now.

17. Open the Level tab to check this.

18. Clear the selection set by clicking somewhere in the view.

19. Close Selecting_Elements.dgn.
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Manipulating Elements
This workbook contains exercises to practice how to manipulate existing elements, by using the Manipulate 
tools.
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Copy and Move

The Copy and Move tools are used to create copies and move elements. You can find both tools on the Home tab in the 
Manipulate group.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Learning.dgn from the \MSBasics\dgn\07 - Manipulating Elements folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Move and Copy Element model by double-clicking it in the list.

5. Close the Models dialog.

You will manipulate the elements on the right according to the examples on the left.
Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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6. Zoom to the cyan lines at the top.

7. Select the Copy tool on the Home tab in the Manipulate group and in the tool settings set the number of copies to 5.

8. Snap to the line on the right.

The AccuDraw compass appears in the snap point.

9. Move the pointer to the right and press Enter to lock the pointer on the axis.

10. Key-in 8 to define the distance and enter a data point to accept.

Five copies are created.

11. Reset to complete.

12. Zoom to the red elements and select Copy again.

13. Make sure the Key Point snap is active and select the circle on the right by snapping to its center point.

14. Snap to each of the corner points of the block to copy the circles.

15. Reset to complete.

16. Then select the Move tool and again snap to the center point of the original circle on the right.

17. In the Snap Mode button bar, click once on the Center Snap icon to activate it temporarily.
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18. Then move the pointer to one of the sides of the block and click there.

The circle is placed exactly at the center of the block.

Note that, when using the Center snap, you have to click on the element itself, not near its center point!

19. Zoom to the green elements at the bottom.

20. Select Move, ensure that the Key Point snap is active, and snap to the center point of the green circle.

To be able to move the circle to exactly the right location in one action, you will recall the AccuDraw compass in a helpful reference point: 
on the mid point of the upper line.

21. Move the pointer (with the circle) to the snap point at the middle of the upper line, but do not click there! Just make sure the yellow x is 
displayed in the snap point.

22. Make sure that the AccuDraw dialog has the input focus. If not, press the F11 key to move the focus there.

23. Then press the O key (O = Origin).

This will place the origin of the AccuDraw compass on the snap point. 
Now you can use AccuDraw to define the exact distance relative to this reference point.

24. Move the pointer downwards and press Enter to lock the pointer on the axis.

25. Key-in 14 and accept with a data point.

The circle is placed at the exact location.
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Move/Copy Parallel

You can use this tool when you want to move or copy an element, or portion of an element, parallel to the original.

1. Continuing in Learning.dgn, open the Models dialog and open the Copy Parallel model.

2. Zoom to the green elements at the top.

3. Select the Move/Copy Parallel tool and in the tool settings select the Element method (first icon).

4. Set the following:

Mode: Miter

Distance: enabled + set to 7.5
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Use Active Attributes: disabled

Make Copy: enabled

5. Select one of the green lines, place a second data point to define the direction of the copy, and reset to complete.

6. As the green lines are all separate lines, you have to repeat these steps for each line.

7. Zoom to the red shapes in the second row.

8. Select Move/Copy Parallel, select the Element method again, and set the following:

Mode: Round

Distance: enabled (You will set the distance graphically.)

Use Active Attributes: disabled

Make Copy: enabled

If the distance is not specified, like in this example, you can set it graphically, by defining two points.

9. Click the Measure Distance icon behind the Distance field.
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10. Snap to the mid point on one of the sides of the inner shape in the left example, and then on the mid point of its parallel copy.

The distance is now set to 6.8.

11. Select the red shape on the right, place a second data point outside the shape, and reset.

The entire shape is copied.
Let’s try to copy only a portion of it.

12. Undo the change.

13. Now select the Segment of Element method (second icon in the tool settings).

14. Select a segment of the red shape, enter a data point outside the shape, and reset.

Only that segment is copied. 

15. Undo the change.

16. Select the Portion of Element method (third icon in the tool settings).

17. Define a start point and an end point on the red shape, enter a data point outside the shape, and reset.

The selected portion is copied.
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It is also possible to parallel copy multiple elements simultaneously.

18. Zoom to the orange elements at the bottom.

19. Select Move/Copy Parallel, select the Element method again, and set the following:

Mode: Miter

Distance: enabled + set to 10

Use Active Attributes: disabled

Make Copy: enabled

20. Drag a selection rectangle around the orange arc and line to select them both.

21. Snap to a point on the arc or line and then place a second data point to define the direction of the first copy.

22. Place another data point to create a second copy.

23. Before creating the third parallel copy, first change the Distance to 2.

24. Then place another data point to create the third copy and reset to complete.

Hint: You could also have used this method when copying the green lines at the top.
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Mirror

The Mirror tool can be used to mirror elements about a horizontal line, a vertical line, an inclined line, or the element 
center.

1. Continuing in Learning.dgn, open the Mirror Elements model.

2. Mirror the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. To mirror the orange triangle at the top, select the Mirror tool and set the following:

Mirror Direction: Vertical

About Element Center: disabled

Make Copy: enabled

4. With the Mirror tool active, drag a selection rectangle to select the three lines that form the triangle (not the arc) and accept the selection.

5. To define the location of the vertical mirror line, snap to the mid point on the arc.

6. Reset to complete.

7. To mirror the green shape, start with the same tool settings and select the green shape by snapping to its lower right corner.

That will bring up the AccuDraw compass in a helpful reference point.

8. Move the pointer to the right and press Enter to lock the pointer on the axis.

9. Key-in the distance to the mirror line, which is 3 (not 6!), and enter a data point to accept.

10. Reset to stop mirroring.

11. To copy and mirror both shapes horizontally, set Mirror Direction to Horizontal.

12. Drag a selection rectangle to select both shapes and accept the selection by snapping to the same corner point.
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The AccuDraw compass again appears in that point.

13. Move the pointer downwards and click on the tick that appears on the axis, which indicates the last used distance of 3.

14. Reset to complete.

15. To mirror the yellow shape about the oblique line, set Mirror Direction to Line.

16. Select the shape and then snap to two points on the red line to define the location and direction of the mirror line.
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Rotate

The Rotate tool is used to rotate elements. You can use one of the following methods:

 Active Angle – The element(s) are rotated by the active angle, which can be entered in the input field.

 2 Points – The rotation angle is defined by entering two data points.

 3 Points – The rotation angle is defined by three data points.

1. Continuing in Learning.dgn, open the Rotate Elements model.

2. Rotate the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. To rotate the red object at the top, activate the Rotate tool and use the 2 Points method.

4. Ensure About Element Center is disabled.

5. Select the object to rotate (a cell, in this case); it does not matter on which point.

6. Snap to the mid point on its left side to define the pivot point (the point to rotate about).

7. Then snap to the end point of the green dotted line to define the rotation angle.

Rotating the green block in the middle is a bit more complicated.

8. Select Rotate with the 3 Points method.

9. First, select the block; it does not matter where.

10. Then define the pivot point, which in this case is the upper left corner of the block.

11. Next, define the start of the rotation by snapping to the lower left corner of the block.

12. Finally, define the amount of rotation by snapping to the lower end point of the oblique line.

The sails of the windmills have to be rotated about their own centers, not as a group. 
In addition, only the yellow sails have to be selected, and not the green windmills. So you will use the Element Selection tool to select 
them in advance and filter them by color.
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13. With Element Selection, drag a selection rectangle to select the windmills and their sails.

14. Expand the tool settings and open the Color tab.

At the top of the list, the colors 4 (yellow) and 2 (green) are selected.

15. Click on the color 2 (green) to deselect it.

The green windmills are removed from the active selection set. Only the yellow sails are selected now (8 elements).
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16. Select Rotate and set the following:

Method: Active Angle 

(Angle): 45

About Element Center: enabled

Copies: disabled

17. Enter a data point to accept the selection, and then reset to complete.

You are returned to the Element Selection tool.

18. Click in the view to clear the selection set.
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Scale

You can use the Scale tool to resize elements, by using one of the following methods:

 Active Scale – The elements are scaled by the active scale factors (X Scale, Y Scale, and Z Scale).

 3 Points – The scale factor is defined graphically, through the entry of three data points.

1. Continuing in Learning.dgn, open the Scale Elements model.

2. Scale the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. To scale the cyan object (that is built of separate lines) activate the Scale tool and set the following:

Method: Active Scale

X Scale / Y Scale: 1.5

Copies: disabled

About Element Center: disabled

4. With the Scale tool active, drag a selection rectangle to select the cyan lines and accept the selection with a data point.

5. Snap to the lower left corner to define the point to scale about.

The green flowers have to be scaled about their own centers, not as a group. 

6. With the Scale tool active, change the scale to 2 and enable About Element Center.

7. Drag a selection rectangle to select the flowers and accept twice.
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To scale the red block, you have to define the scale factor graphically.

8. Select Scale and set the following:

Method: 3 Points

Copies: disabled

Proportional: enabled

About Element Center: disabled

9. First, select the block; it does not matter where.

10. Define the base point for scaling, in this case the mid point at the bottom of the block.

11. Next, define the current length of the block by snapping to the mid point at the top of the red block.

12. To define the new length, move the pointer upwards and press Enter to lock the pointer to the AccuDraw axis.

13. Then snap to the mid point (or one of the end points) of the blue line.

The scale factor is calculated by dividing the new length by the old length.
Because Proportional was enabled, the block is also scaled in the horizontal direction.
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Array

This tool is used to copy an element many times to create a rectangular or a polar (circular) array, or an array along a 
path element.

1. Continuing in Learning.dgn, open the Array Elements model.

2. Manipulate the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. Use Array with the Rectangular method to copy the tree to both sides of the road in one action.

4. Ensure the Active Angle is set to 0.

5. Set the number of (horizontal) rows and (vertical) columns. (These are always positive values.)

6. Set the spacing between the rows (vertical distance) and between the columns (horizontal distance). Note that the spacings can be 
negative, to copy the original element downwards or to the left.

7. Select the tree (a cell) and accept the selection.

8. To copy the cyan object around the circle select the Polar method.

9. When counting the number of items, do not include the original element, only the copies.

10. Instead of calculating the angle between the items yourself, you can just key-in the number of copies (8) and the total angle (360).

Then MicroStation will calculate the value of the delta angle for you.

11. Enable Rotate Items to rotate the items while they are copied.
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12. Select the object to copy and snap to the center of the circle to define the center point of the array.

13. To create the winding staircase also use the Polar method.

14. Note that the steps overlap each other, so the angle between the items is smaller than 15°.

15. Snap to the center of the little cross to define the center point of the array.
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Stretch

The Stretch tool allows you to extend or shorten elements by moving the end points and vertices that lie within a fence.

1. Continuing in Learning.dgn, open the Stretch Elements model.

You will manipulate the elements on the right according to the examples on the left.

2. To stretch the object at the top, select the Stretch tool and place a fence around the right half of the object.

3. Snap to the lower right corner point, move the pointer to the right, and press Enter to lock the pointer to the AccuDraw axis.

4. With the focus in the AccuDraw dialog, key-in 44.4–29.9 and accept with a data point.

5. Reset to complete.

Note that the dimension is automatically updated, as it is associated to the cyan object.

In the next drawing, you will use Stretch to move a window frame along a wall, without changing its size, a typical and powerful use of this 
tool.

6. Select Stretch and place the fence so that it includes the complete window frame.
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7. Snap to the upper left corner of the green window frame.

You will recall the AccuDraw compass in the end point of the wall, so that you can define the exact location of the window frame relative 
to that point.

8. Move the pointer to the left, to the snap point at the end of the wall, but do not click there! Just make sure the yellow x is displayed in the 
snap point.

9. Make sure that the AccuDraw dialog has the input focus. If not press the F11 key to move the focus there.

10. Then press the O key (O = Origin).

This will place the origin of the AccuDraw compass on the snap point. 

Now you can use AccuDraw to define the exact distance from this reference point.

11. Move the pointer to the right and press Enter to lock the pointer on the axis.

12. Key-in 10 and accept with a data point.

13. Reset to complete.

The window frame is moved to the exact location in the wall, and the wall lines are stretched.

When using Stretch, the most important thing is to place the fence carefully, so that it includes the vertices that you want to move.
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14. Select Stretch again and in the drawing at the bottom place the fence around the vertices that must be moved.

15. Snap to one of the vertices in the fence, move the pointer upwards, and press Enter to lock the pointer to the AccuDraw axis.

16. Key-in 54–33 and accept with a data point.

17. Reset to complete.

18. Close Learning.dgn.
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Modifying Elements
This workbook contains exercises to practice how to modify existing elements, by using the Modify tools.
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Modify Element

Modify Element is a multi-purpose modification tool that is used to change the spatial coordinates of an element’s 
geometry. You can do various things with this tool, depending on the element you select.

 Move a vertex or segment of a line, line string, or shape. 

 Resize a block about the opposite vertex.

 Modify rounded segments of complex chains and complex shapes created with the Place SmartLine tool.

 Change a circle's radius.

 Modify an arc in various ways.

 Change the type of a vertex (sharp, rounded, or chamfered).

The tool settings of the Modify Element tool change depending on the element or vertex selected. You can find the tool 
on the Home tab in the Modify group

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Learning.dgn from the \MSBasics\dgn\08 - Modifying Elements folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.
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3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Modify Elements model by double-clicking it in the list.

You will modify the elements on the right according to the examples on the left.

5. Zoom to the cyan lines at the top.

6. Select the Modify Element tool and move the end points of the three upper lines.

7. To change the radius of the red circle on the right, select the circle with Modify Element.

The polar AccuDraw compass appears in the center of the circle.

8. Key-in the new radius in the Distance field in the AccuDraw dialog and accept with a data point.

Note that, when moving the end point of a line or changing a circle’s radius, no tool settings are available.
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9. With Modify Element click on a corner point of one of the green orthogonal complex chains on the right.

Now there are tool settings displayed.

10. Move the pointer and note the change when you toggle the Orthogonal tool setting on and off.

11. Reset to keep the original elements (or Undo if necessary).

12. Click on one of the corner points again.

13. In the tool settings, change Vertex to Rounded and set the desired Radius.

14. Expand the tool settings and set Vertex Settings to Last Used.

15. Then snap to the original corner point.

This is how you change the vertex type of vertices on complex chains or complex shapes from sharp to rounded or chamfered, or vice 
versa. You can not use Construct Fillet or Construct Chamfer on complex elements.

16. Repeat this for the other three corner points.
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17. With Modify Element activated, snap to the midpoint on the orange arc that is part of a complex shape.

18. In the tool settings, ensure that the Method is set to Radius about Center and move the pointer.

This modifies the arc’s radius without changing the center point.
The polar AccuDraw compass displays and the focus is moved to the Distance field in the AccuDraw dialog.

19. Key-in the new radius and accept with a data point.

20. Snap to the midpoint on the orange arc again and change the method to Radius preserve Ends.

This method modifies the arc by changing the radius, but keeps the end points in the same place.

21. Reset.
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Insert Vertex and Delete Vertex

With the Insert Vertex and Delete Vertex tools you can insert a vertex in or delete a vertex from a linear element.

1. Continuing in Learning.dgn, open the Models dialog and open the Insert and Delete Vertex model.

2. Modify the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. To modify the green block on the right, select Insert Vertex and snap to the midpoint on the upper side of the block.

The AccuDraw compass appears in the midpoint.

4. Move the pointer upwards and press Enter to lock the pointer on the axis.

5. Key-in 20 to define the distance and enter a data point to accept.

6. Repeat this for the other three midpoints.

7. To remove the spikes in the orange object, select Delete Vertex and for each spike delete the three vertices that define it.

Hint: Start with deleting the two vertices at the base of each spike. That makes it easier to see which vertices are left.
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Break Element

Break Element is used to remove unwanted portions of elements. It has four methods:

 Break by Two Points – To delete part of an element by defining two points.

 Break by Point – Breaks the element at a defined point.

 Break by Drag Line – Breaks the element(s) by drawing a virtual line that intersects the element(s).

 Break by Elements – Breaks the element(s) by one or more intersecting elements.

1. Continuing in Learning.dgn, open the Models dialog and open the Partial Delete model.

2. Zoom to the orange objects in the third row.

3. Select Break Element and the Break by Two Points method.

You will define the start point of the break at exactly 10 master units from the lower right corner.

4. Without entering a data point, snap to the lower right corner of the orange line string on the right.
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5. Move the focus to the AccuDraw dialog and press the O key (Origin), to display the AccuDraw compass in the corner point.

6. Move the pointer upwards and press Enter to lock the pointer on the axis.

7. Key-in 10 to define the distance and enter a data point to accept.

This is the start point of the break.

8. Move the pointer upwards and press Enter again to lock the pointer on the axis.

9. Key-in 15 to define the distance and enter a data point to accept.

This is the end point of the break.

10. Zoom to the circles in the second row.

11. Select Break Element and the Break by Point method.

12. Snap to the two keypoints on the right circle.

The circle is divided into two arcs.

13. Select Move Element and move the clipped part of the circle.

14. Select Break Element and the Break by Drag Line method.

15. Enter two data points to define a virtual line that intersects the larger arc.

16. Select Move Element and move the clipped part of the arc.
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17. Place a block and a line that each intersect an arc.

18. Select Break Element and the Break by Elements method.

19. Select the first cutting element, press the Ctrl key, and select the second cutting element, then release the Ctrl key.

20. Select the first element to cut, press the Ctrl key, and select the other elements to cut.

21. Release the Ctrl key and accept with a data point.

22. Select Move Element and move the clipped parts of the arcs to show that the arcs are clipped.
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Trim to Intersection

With this tool you can extend or shorten two open elements to their intersection.

1. Continuing in Learning.dgn, open the Trim to Intersection model.

2. Modify the elements on the right according to the examples on the left. 

Make sure that you select the elements on the part you want to keep. If it goes wrong, select Undo (or press Ctrl + Z) and try again.
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Extend elements with Trim to Element

The Trim to Element tool lets you extend or trim an element, or multiple elements simultaneously, to their intersection 
with one other element (in one direction). When trimming, you need to select the parts that will remain.

1. Open TrimToElement.dgn from the \MSBasics\dgn\08 - Modifying Elements folder and open the Trim To Element model.

The green and the red elements are all line strings. You will extend the green elements to the red element.

2. Select the Trim To Element tool and ensure that the Select cutting element first tool setting is disabled.

The prompt asks you to select the elements to modify first.

3. Drag a selection line across the end segments of two green elements.

4. Press the Ctrl key and also select the end segment of the remaining green line (or drag a selection line across it).
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The elements are highlighted and the end segments are thickened.

5. Select a cutting segment on the red element.

All three segments are extended to their intersections with the selected cutting segment.

6. Undo the change.

In order to extend the green elements to the entire red element (instead of to a segment of the red element), you have to select the cutting 
element first.

7. Select Trim To Element and enable the Select cutting element first tool setting.

8. Select a segment on the red element.

Only the selected segment is highlighted. To highlight the entire element do the following.

9. Reset (press the right mouse button) to select the entire red element.

The entire red element will be used as cutting element now.
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10. Press the Ctrl key and drag one or more selection lines across the end segments of the green lines to extend them.

11. Accept with a data point.

Each segment is extended to its intersection with the entire cutting element.

Next, you will use this tool to shorten elements.

12. Copy the red line string to the left so that it intersects the green elements.

13. Select Trim To Element and ensure the Select cutting element first tool setting is enabled.

14. Select a segment on the copied red element and reset to select the entire element as cutting element.

15. Drag a selection line across the end segments of the green elements, left of the cutting element, to shorten them.
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Note that you have to select the portions of the elements that must remain. Each segment is shortened to its intersection with the entire 
cutting element.
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Trim Multiple

Trim Multiple allows you to extend or trim one element, or multiple elements simultaneously, to their intersection with 
one or more other elements (in multiple directions). When trimming, you need to select the parts that will be deleted.

1. Open Learning.dgn from the \MSBasics\dgn\08 - Modifying Elements folder.

2. Open the Trim Multiple model.

The objects in the left column show the desired results. You can try out the Trim Multiple tool on the elements in the right column. 

3. Zoom to the objects in the second row.

4. Select Trim Multiple and select the Trim method.

5. First, select the circle on the right as the cutting element.

6. Drag a selection line across the lines within the circle to identify the elements to trim.

Note that with this tool you must select the parts of the elements that will be deleted.

7. Reset to complete.
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8. Zoom to the objects in the third row.

9. Select Trim Multiple and the Trim and Extend method.

With Trim Multiple you can select multiple cutting elements. (With Trim to Element, you can select only one cutting element.)

10. Select the vertical line on the right as cutting element, press the Ctrl key, and select the arc as well.

11. Drag a selection line across the lines between both cutting elements to delete the parts of the elements between the line and the arc, just 
like in the example on the left. 

12. Reset to complete.

13. Draw an oblique line at the right of the arc.

14. Select Trim Multiple and the Trim and Extend method.

15. Select the oblique line as the cutting element.

16. Drag a selection line across the lines between the arc and the oblique line to identify the elements to extend.

17. Reset to complete.

18. Delete the oblique line.
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19. Copy the vertical line as in the following image.

You will extend the upper green lines and trim the lower green lines.

20. Select Trim Multiple and the Trim and Extend method.

21. Select the copied line as the cutting element.

22. Drag a selection line across the lines between the arc and the copied line to identify the elements to trim and extend.

The result is not what you wanted, because the wrong parts of the lower green lines are deleted.

23. Undo the change.

24. Select Trim Multiple and the Trim and Extend method.

25. Select the copied line as the cutting element.

26. First, drag a selection line between the arc and the copied line to identify the elements to extend (the upper green lines).
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27. Then, drag a selection line at the right of the copied line to identify the elements to trim.

28. If needed, select the smallest parts to trim individually.

29. Reset to complete.

Hint: In this last exercise, it’s easier to use the Trim to Element tool instead, because it allows you to select all elements to modify on the 
left side of the cutting line.
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Extend Line

The Extend Line tool lets you extend or shorten a line, dynamically or by defining a positive or negative distance in 
advance.

1. Continuing in Learning.dgn, open the Models dialog and open the Extend Line model.

2. Modify the lines on the right according to the dimensions on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.



Copyright © 2016 Bentley Systems, Incorporated 21DO NOT DISTRIBUTE - Printing for student use is permitted

3. For the cyan line at the top the extension is not specified. So you can just select the line near the upper end point and graphically extend 
it.

4. To extend the red line, enable the Distance tool setting and set it to 15.23. 

5. Then select the line near the upper end point and accept with a data point.

6. To shorten the green line, ensure the Distance tool setting is still enabled and set it to ‐10 (note the minus sign!). 

7. Then select the line near the lower end point and accept.

8. To extend the orange line to a total length of 39.23 units, disable the Distance tool setting first.

9. Select the line near the upper end point. 

The polar AccuDraw compass displays in the other end point and the focus is moved to the Distance field in the AccuDraw dialog.

10. Key-in the desired length and accept with a data point.
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Construct Fillet and Construct Chamfer

The Construct Circular Fillet and Construct Parabolic Fillet tools can be used to construct a circular or parabolic fillet 
between two elements or segments. 
To construct a chamfer between two lines or adjacent segments of a line string or shape, you can use the Construct 
Chamfer tool.

1. Continuing in Learning.dgn, open the Fillet and Chamfer model.

2. Modify the elements on the right according to the examples on the left.

Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.
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3. To construct circular fillets between the green lines select Construct Circular Fillet, set the Radius to 7.5, Truncate to Both, and select two 
lines. 

Hint: To ensure that the new arcs get the same symbology as the existing lines, you can first set the active attributes to the correct values 
by holding the Alt key down and selecting one of the green lines (match attributes fromcursor).

4. To complete the red figure in the middle, you have to use Construct Circular Fillet, set the Radius, and toggle the Truncate setting 
between None, Both, and First, depending on if the existing lines should be modified or not. 

5. Watch the example carefully and use Undo to make corrections.

Note that it is possible to construct a circular fillet between arcs.

6. Select Construct Chamfer to create a chamfer between the orange lines. 

Note that the value of Distance 1 is applied to the line you select first.

7. Close Learning.dgn.
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Working with Cells
This workbook contains exercises to practice how to place, create, edit, and replace cells.



Copyright © 2016 Bentley Systems, Incorporated 2DO NOT DISTRIBUTE - Printing for student use is permitted

Place cells

Cells are complex elements that represent objects or symbols you use regularly in your designs. Cells can be created 
from any combination of elements and are stored in an external file, a cell library. After attaching a cell library, you can 
easily place the cells into the design.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Using_Cells.dgn from the \MSBasics\dgn\09 - Working with Cells folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Cells model by double-clicking it in the list.

5. On the Annotate tab, locate the Cells ribbon group.

When working with cells, you usually need to open the Cell Library dialog, as that is where you can attach a cell library and view the 
available cells.
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6. In the Cells ribbon group, click the small button in the lower right corner. This button is called the dialog launcher and it opens the Cell 
Library dialog.

No cell library is attached, so no cells are listed.

Note: If any cells are listed, ensure that the buttons Show Shared and Parametric Cell Definitions and Display All Cells In MS_CELLLIST 
are disabled.

7. In the Cell Library dialog, select File > Attach File.

8. Navigate to the \MSBasics\Standards\Cell folder in the course dataset and open the cell library interior.cel.
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The cell library is attached to the design file and the cells in the library populate the dialog.

9. Click on each of the cells in the list to preview them.

You can easily place a cell by double-clicking it in the list.

10. Double-click the cell CHAIR1.

This makes this cell the active cell for placement and activates the Place Active Cell tool.

11. In the tool settings, set the following:

Active Cell: CHAIR1 (already set correctly, because you double-clicked it)

Active Angle: 0

X Scale: 1

Y Scale: 1
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12. Expand the tool settings by clicking the arrow in the lower right corner and ensure that True Scale is enabled.

13. Place the cell several times in the floor plan.

14. Without resetting, change the Active Angle tool setting to ‐90 (or 270) and place some rotated cells.

Hint: You can use the arrows next to the Active Angle field to set the angle to predefined values.

15. Reset to stop placing this cell.

16. Add some more furniture to the floor plan by double-clicking other cells in the Cell Library dialog and placing and rotating them.
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Important: If a cell defines an object with a real world size, such as a chair or a door frame, it should always be placed with scale 1. Only 
cells that define a symbol may be scaled.

Note: The reason that True Scale must be enabled is that the cells in this cell library interior.cel are defined in inches, while the Master 
Unit in the active model is set to meters. If True Scale is off, the cell will be the wrong size. When it is on, MicroStation reads the units in 
which the cell was created, compares these to the active model’s working units, and automatically corrects the size of the cell if the units 
are not the same.
So it is best practice to have True Scale always enabled when placing cells.

Hint: Another way to activate the Place Active Cell tool is by selecting it on the Annotate tab in the Cells group, or on the Home tab in the 
Placement group.

Another way to open the Cell Library dialog after activating the Place Active Cell tool is by clicking the Browse Cell(s) button behind the 
Active Cell field.
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Place cells as line terminators

A cell can be made active for placement, but also to be used as a line terminator or for patterning. When placing a cell 
as a line terminator, it is automatically placed at the end point of and aligned with the selected line. 

1. Continuing in Using_Cells.dgn, in the Cells model, draw some oblique lines with Place SmartLine. 

You will select a line terminator cell from another cell library.

2. In the Cell Library dialog, select File > Attach File.

3. In the \MSBasics\Standards\Cell folder, select and open the cell library geompa.cel.

Different cells populate the dialog now.

4. Scroll down the cell list and select the LT5 cell.

5. Click the Terminator button to set this cell as the active terminator cell.

Instead of using the ‘normal’ Place Active Cell tool, you will now use the Place Active Line Terminator tool.
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6. Right-click on the LT5 cell in the list and select Place Terminator in the context menu.

7. In the tool settings, set the following:

Active Cell: LT5 (already set correctly, because you clicked the Terminator button)

Scale: 0.01

8. Select an oblique line near one of its end points and accept with a data point.

Hint: You do not have to snap to the line as the tool will automatically search for the nearest end point.

9. Place some more line terminators by clicking on other lines.
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Create cells

If allowed within your organization, you can create new cells and store them in an existing cell library or in a new cell 
library. This is how you create a new cell.

 Attach an existing cell library or create a new one.

 Draw the contents of the cell on the desired levels.

 Select all the elements to be included in the cell, with Element Selection or a fence.

 Define the cell origin using the Define Cell Origin tool.

 In the Cell Library dialog, click the Create button and define the name, description, and type of the cell.

 (Delete the elements that you used to create the cell.)

1. Continue in Using_Cells.dgn, in the Cells model. 

You will create a new cell library first to store your new cells in.

2. In the Cell Library dialog, select File > New.

3. In the Create Cell Library dialog, navigate to the \MSBasics\Standards\Cell folder, where the other two cell libraries are stored.

4. In the File Name field, type training as the name of the new cell library file and click Save.

The new cell library training.cel is created and attached to the active design. The cell library is empty.

5. On the Home tab in the Attributes group, set the active level to geometry.

6. Draw a figure that consists of multiple lines, circles, or shapes, using different colors and line styles, if you like.
The elements may be on different levels.

7. With Element Selection, select the elements that together will form the cell.

When placing a cell, it is attached to the pointer at a certain point: the origin point of the cell. This cell origin is defined when creating the 
cell.



Copyright © 2016 Bentley Systems, Incorporated 10DO NOT DISTRIBUTE - Printing for student use is permitted

8. On the Home tab in the Placement group, select the Define Cell Origin tool.

Hint: You can also find this tool in the Cells group on the Annotate tab.

9. Snap to the point that should be the origin of the new cell.

A small cross indicates the active origin. This origin stays active until you click the Define Cell Origin tool again.

10. In the Cell Library dialog, click the Create button.

Hint: Make sure that you first select the elements and then define the cell origin, otherwise the Create button remains grey and can not be 
used.
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11. In the Create Cell dialog, type a name and a description for the new cell, ensure that the cell type is set to Graphic, and click Create.

The cell is added to the library.

12. Delete the original elements that the cell was created from and click Define Cell Origin again to remove the active origin.

13. Double-click the cell in the cell list and place it several times in the design.

14. Create two more cells and store them in the same cell library training.cel.

15. Place the cells in the design and check if the origin points are correct.

Note: Do not remove the cells from the design, as you will use them in one of the next exercises, to practice how to replace cells.

16. Select Save Settings in the Quick Access Toolbar (or press Ctrl + F) to ensure that the cell library training.cel is automatically attached 
next time you open this design file.
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Edit cells

There are two ways to modify the contents of a cell.

 Place the cell in the design and drop it with the Drop Element tool and the Complex tool setting enabled. Then 
make your changes and create a new cell. To be able to use the old cell name, you have to delete the old cell from 
the cell library first (Delete button), or rename it (click twice on the cell name).

 Edit the cell as a model.

The second method is the easiest. 
Important! A cell library file in fact is a normal DGN file. Each cell in the cell library is a model in the DGN file. So it is 
possible to open the cell library just like a DGN file, then open the model (= the cell), and modify its contents.

1. Continue in Using_Cells.dgn, in the Cells model.

You can manually open the cell library file by clicking the File tab and on the backstage click the Browse button, but that is not necessary.
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2. In the Cell Library dialog, right-click the cell whose contents you want to modify and in the context menu select Open for Editing.

The cell library is opened as the active DGN and the selected cell is opened as the active model.

3. Note the file name in the title bar of the MicroStation application window and the model/cell name in the view window’s title bar.

4. Make some changes to the model/cell, for example, delete or add an element.

5. To return to your design click the Previous Model icon at the lower left of the application window.
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6. In the Cell Library dialog, select the cell and note that the preview of the cell is updated.

The (old) cells in the design have not been updated yet. You can update them using the Replace Cells tool, as explained in the next 
exercise.
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Replace cells

With the Replace Cells tool, you can:

 Replace cells by cells with another name.

 Update cells with cells with the same name from the active cell library.

You can select the cells to be replaced or updated yourself, or you can replace or update them globally.

1. Continue in Using_Cells.dgn, in the Cells model.

In the previous exercise, you modified the contents of one of your cells. That cell was updated in the cell library, but the instances of that 
cell that were already placed in the design are not updated yet. Let’s do that first.
So you want to update those old cells: replace them by the new modified cell with the same name from the library.

2. On the Home tab in the Placement group, select the Replace Cells tool.

Hint: You can also find this tool in the Cells group on the Annotate tab.
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3. In the tool settings, set the following:

Method: Update

Mode: Global

4. Following the prompt, select one of the old cells that you want to update and accept with a data point.

Because you are in global replacement mode, MicroStation will update all cells with the same name and wants a confirmation from you.

5. Click Yes in the Alert dialog.

All cells with the same name are updated and replaced by the new cell with that same name from the cell library.

If you want to replace only certain cells with a cell with another name, you should use the Replace method and select the cells yourself.
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6. With Element Selection, select the cells you want to replace. Note that you can select cells with different names!

You can define the replacement cell by setting it as the active cell in the Cell Library dialog, or by selecting it in the design graphically. 
Let’s select it graphically.

7. Select Replace Cells and set the following:

Method: Replace

Mode: Single

Use Active Cell: disabled
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8. Following the prompt, select the replacement cell and accept with a data point.

The selected cells are replaced by the selected replacement cell.

9. Close Using_Cells.dgn.
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Annotating Designs
This workbook contains exercises to practice how to place and edit texts, dimensions, and patternings.
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Place texts with different text styles

Using the Place Text tool you can place single-line as well as multi-line texts. You can find the Place Text tool on the 
Annotate tab in the Text group (and also on the Home tab in the Placement group).

Best practice to define the appearance of texts is by using predefined text styles. Text elements placed with a text style 
are automatically updated if the text style is modified.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Annotating_Designs.dgn from the \MSBasics\dgn\10 - Annotating Designs folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Print Sheet model by double-clicking it in the list.

This is a full-size sheet model (A1, 1:1) with several design models attached as references.
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5. On the Annotate tab in the Text group, select Place Text and set the following tool settings:

Method: By Origin

Annotation Scale: enabled (depressed)

Active Angle: 0

View Independent: disabled

6. In the text editor, set the following:

Text Style: Arial 10 mm

7. Type the following text in the text editor: South Elevation.

The text is attached to the pointer at its upper left corner, because in the Arial 10 mm text style the Justification is set to Left Top.

8. Place the text below the elevation at the top of the sheet and then reset.

The reset clears the text editor.

9. Type the following in the text editor: Floor Plan.

10. Press Enter to start a second line of text and type: Atrium.
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11. View the text that is attached to the pointer.

A single line of text is a text element, while multi-line text is referred to as a text node. Text nodes are complex elements; they are made 
up of multiple text elements.
Before placing the multi-line text, you will change the text style and the justification.

12. While the text is already attached to the pointer, change the Text Style attribute in the text editor (= first setting on the left) 
to Comic Sans 10 mm.

The appearance of the text changes, because of the different text style.

13. Also change the Justification attribute (= last setting on the right) to Middle Center.

14. Place the text below the floor plan and reset.

Best practice is to use a predefined text style to set the text attributes. 
Text styles are defined in the Text Styles dialog.
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15. Open the Text Styles dialog by clicking the Open Text Styles Dialog button in the text editor.

It is possible to override the text attributes in the active text style by manually changing them, in the text editor or in the Text Styles dialog. 
When a text attribute is overridden, its label - and the text style name and tab label - are displayed in blue.
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16. Click the Revert Style button in the text editor to change the Justification attribute back to its original value.

The labels in the Text Styles dialog display in black again.

17. Close the Text Styles dialog.
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Place texts using different methods

There are different methods to place text, such as By Origin, Fitted, or Above Element. You can find these methods in 
the Place Text tool and in the Place Text Along tool. Both tools can be found on the Annotate tab in the Text group.

1. Continuing in Annotating_Designs.dgn, in the Print Sheet model, zoom in to the floor plan.

2. Select Place Text and set the following:

Method: By Origin

Annotation Scale: enabled (depressed)

Active Angle: 30

View Independent: disabled

3. In the text editor, set the following:

Text Style: Arial 5 mm

4. Type the following into the text editor: Example Text.

5. Place the text in one of the rooms in the floor plan, and do not reset.

6. While the text is still attached to the pointer for another placement, change the following tool setting:

Method: Fitted
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The text is not attached to the pointer anymore, because you have selected the Fitted method.

7. Enter two data points to place the text fitted between those points.

The text size and angle are automatically adjusted.

8. Without resetting, select the Place Text Along tool on the Annotate tab in the Text group.

9. In the tool settings, set the method to Above Element.

10. Select a point on the oblique line on the left of the floor plan and accept with a data point, to place the text parallel to that line.

The distance that the text is placed from the identified element depends on the Line Spacing text attribute. The larger the value, the 
further away from the element the text is placed. The line spacing is set in text height units.

To practice two other text placement methods, you first have to draw a line and an arc.

11. With Place SmartLine draw an oblique line and with Place Arc draw an arc.
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12. Select Place Text Along again and change the method to On Element.

13. In the text editor, change the Justification to Top Center.

14. Again type Example Text into the text editor, select a point on the new line, and accept with a data point.

This time, the text is placed on the line and the line is removed where the text is placed.

To place a text along a curved element, you can use the method Along Element.

15. Without resetting, in the tool settings change the method to Along Element.

16. In the text editor, click the Open Text Styles Dialog button.

17. In the Text Styles dialog, on the Spacing tab, change the Line Spacing to 2.
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18. Snap to the mid point on the arc.

19. Move the pointer to either side of the arc to review the two options to place the text.

20. Enter a data point inside or outside the arc to accept the desired location.
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Use annotation scale

The annotation scale is an optional scale factor that can be applied to text elements (and to several other elements) to 
change their size according to the print scale. 
For example, when you intend to print a design with scale 1:100, the texts have to be placed 100x larger than you want 
them to appear on paper. So if the text height on paper should be 5 mm, the text height in the design must be 500 mm.
The annotation scale can take care of this. 

 First set the annotation scale for the model in the model properties, via the Models dialog.

 Then turn on the annotation scale lock to apply the annotation scale when you place a text in the model.

Applying the annotation scale will ensure that, when the scaled print is created, annotations are at the correct physical 
size.

(The annotation scale can also be applied to dimensions, annotation cells, hatchings and patternings, the sheet 
boundary in a sheet model, detailing symbols, tags, and (cosmetic) line styles.)

1. Continuing in Annotating_Designs.dgn, open the Ground Floor Plan model.

This is a design model containing a 2D floor plan that will be printed with scale 1:100. An A1 border is attached with a reversed scale 
factor 100:1.

2. Open the Models dialog and select the Ground Floor Plan design model in the list.

3. In the Models dialog’s toolbar, click Edit Model Properties.
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4. In the Properties dialog, set the annotation scale to 1:100.

5. Select Place Text with the following tool settings:

Method: By Origin

Annotation Scale: enabled (depressed)

Active Angle: 0

View Independent: disabled

6. In the text editor, set the Text Style to Arial 10 mm and type: Ground Floor Plan.

7. Place the text below the floor plan and do not reset.

8. With the text still attached to the pointer, hold the pointer still on the annotation scale lock icon in the tool settings and read the pop-up 
text.
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Currently, the annotation scale lock is on and new text elements are enlarged with a factor 100.

9. Disable the annotation scale lock and place the second text element somewhere in the design, then reset.

The text is much too small now, as its text height is 10 mm instead of 100x10 mm.

10. Zoom in to view the small text and delete it.

11. Fit the view.

It is a good practice to have the annotation scale lock always enabled, even when the annotation scale is set to 1:1, like in the sheet 
model in the previous two exercises. It allows you to quickly change the size of all texts, in the event that you need to change the scale of 
the drawing. Simply change the Annotation Scale setting for the model.

Let’s try that out. Suppose you want to print the design with a print scale of 1:200 instead of 1:100, but the texts should still be 10 mm on 
paper. So the texts in the design should be made 2x larger.

12. In the Models dialog, click Edit Model Properties and set the annotation scale to 1:200.

The texts in the design are scaled by a factor 2.

13. Reset the annotation scale for this model to 1:100.

14. Select Save Settings in the Quick Access Toolbar (or press Ctrl + F).
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Edit or change texts

The Edit Text tool lets you edit existing texts. When a text string is selected for editing, it appears in the text editor. In 
addition to changing the text content, you can also change the text style and a variety of text attributes. Once the 
changes have been made, click in the view to update the text in the design.

To control the appearance of text, you can use:

 Match Text Attributes – To set the active text attributes to match those of a selected text element.

 Change Text Attributes – To change the text attributes of existing text elements to the active text attributes.

The Find/Replace Text tool allows you to edit multiple texts in one action. 

You can find all these tools on the Annotate tab in the Text group.

1. Continuing in Annotating_Designs.dgn, reopen the Print Sheet model.

2. On the Annotate tab in the Text group, select Edit Text.

3. In the design, select the text South Elevation.

The text appears in the text editor.

4. In the text editor, change the word South into North.
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5. Click in the view to update the text in the design.

Let’s change the appearance of this text, by assigning it the same text style as is used for the Floor Plan Atrium text. You will first set the 
active text style by matching it to the text style of the Floor Plan Atrium text and then change the text style of the North Elevation text.

6. On the Annotate tab in the Text group, select the Match Text Attributes tool.

7. Select the text element with the required text style: Floor Plan Atrium.

8. Following the prompt, accept with a data point.

9. Then select the Change Text Attributes tool.

10. In the tool settings, ensure that the Text Style check box is enabled and note that the active text style is set to Comic Sans 10mm, the text 
style of the Floor Plan Atrium text.

The text style label is displayed in blue, because you had overridden the Justification attribute when placing the Floor Plan Atrium text. 

11. Select the North Elevation text. 

The appearance of this text is changed.

If you want to replace multiple instances of the same text string with another text string, it is easier to use the Find/Replace Text tool 
instead of the Edit Text tool.
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12. On the Annotate tab in the Text group, select Find/Replace Text.

13. In the Find/Replace Text dialog, set the following:

Find: Example Text (or another text string that is in your design multiple times)

Replace: New Text

Animate: enabled

Zoom: enabled + drag the zoom slider a bit to the right

Rotate: disabled

14. Click the Find button.

MicroStation zooms in to the first text element that contains the text string.
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15. Click Replace to replace the text string and zoom to the next text element. 
Or click Find to keep the text as it is and find the next text element.

When the search is complete a message appears.

16. Enable Restore Original View and click OK.

17. Close the Find/Replace Text dialog.
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Place dimensions

MicroStation has many dimensioning tools. Additionally, a large number of dimension attributes defines the appearance 
of dimensions. The easiest way to set these dimension attributes is by using predefined dimension styles. Dimension 
elements placed with a dimension style are automatically updated if the dimension style is changed.

A dimension can be associated to the element being dimensioned. If the element is then modified, the dimension 
automatically updates to reflect the change.

You can find the dimensioning tools on the Annotate tab in the Dimensioning ribbon group.

1. Continuing in Annotating_Designs.dgn, open the Ground Floor Plan model.

2. Zoom in to the area that is displayed in this image.
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3. On the Annotate tab in the Dimensioning group, select the Dimension Element tool.

This tool makes it very easy to dimension one element at a time, whether it is linear or circular. 

4. Expand the tool settings and set the following:

(Dimension Style): mm Dimension

Alignment: View

Location: Automatic

(Tool): Dimension Element

Annotation Scale: enabled (depressed)

Start Extension: enabled + arrow

End Extension: enabled + arrow

Association: enabled

5. Select the right side of the wall behind the circular reception desk, move the pointer to the right, and place the dimension.

Note that with the Dimension Element tool you do not have to snap to the end points of the line; you can just select it anywhere.
Which tools the Dimension Element tool offers depends on the type of element you select.
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6. Continuing with the Dimension Element tool, select the outer arc of the reception desk.

7. Note that different tool icons are available now in the tool settings.

8. Ensure Dimension Radius is selected in the tool settings and place the radial dimension.

Currently, linear dimensions are placed horizontal or vertical, parallel to the view axes. If you want to place a dimension parallel to an 
oblique line, you have to change the Alignment tool setting.

9. On the Home tab in the Placement group, select Place Block, set the method to Rotated, and place a rotated block in the hall.

10. Select the Dimension Element tool and in the tool settings set the Alignment to True.

11. Dimension both sides of the block.

You will extend the wall behind the reception desk to see if the dimension indeed is updated. It should be, as you enabled the Association 
tool setting before you placed the dimension.
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12. On the Home tab in the Modify group, select Modify Element.

13. Snap to the upper end of the wall, move the pointer upward to extend the wall, and enter a data point.

The dimension is automatically updated.

Using the Dimension Linear tool you can place multiple linear dimensions in line (chained) or stacked.

14. Zoom to the corridor at the bottom of the floor plan.

15. On the Annotate tab in the Dimensioning group, select the Dimension Linear tool.

16. In the tool settings, set the Alignment to View and select the first of the three tool icons: Linear Size.

17. Snap to the point where the dimension should start.

18. Snap to the next dimension point.
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19. The third point defines the location of the dimension line.

20. Snap to the next dimension points until the dimension is complete, then reset.

Hint: The other two tool icons in the tool settings, Linear Stacked and Linear Single, let you dimension the linear distance from an origin, 
while placing the dimensions stacked or in line.

An easy way to dimension an angle is as follows.

21. On the Annotate tab in the Dimensioning group, select the Dimension Angular tool.

22. In the tool settings, select the third tool: Angle Between Lines.

23. Following the prompt, select the first line and then the second line.
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24. Finally, define the location of the dimension arc.
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Change dimensions

It is possible to edit the dimension text of existing dimensions, or to change its appearance by applying another 
dimension style. You can even modify the geometry of a dimension element, by moving the dimension line or text, or by 
adding, moving, or removing extension lines.

1. Continuing in Annotating_Designs.dgn, in the Ground Floor Plan model, zoom to the linear dimensions in the corridor.

2. On the Home tab in the Modify group, select Modify Element.

3. Select the horizontal dimension line and move it a bit upward or downward.

4. Select one of the dimension texts and move it along the dimension line to the right or left.

Suppose you picked one dimension point too much.

5. On the Home tab in the Modify group, select Delete Vertex.

6. Select one of the extension lines to remove it.
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Note that the dimension text is automatically updated.

In case you forgot to dimension a certain point, you can easily add it afterwards.

7. On the Home tab in the Modify group, select Insert Vertex.

8. First, select the horizontal dimension line and then snap to the point you want to dimension.

An extension line is added.

In case you snapped to the wrong point, you can move an extension line afterwards to correct it.

9. Select Modify Element.

10. Select the extension line and snap to the correct point.

The dimension texts on both sides of the extension line are updated.
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This is how you can edit a dimension text.

11. On the Annotate tab in the Text group, select Edit Text.

12. Select a dimension text.

In the text editor, the automatically generated dimension text is represented by an asterisk *. You can replace the asterisk or add text 
before or after it.

13. Replace the asterisk by the text hello and click in the view.

Hint: You can always return to the automatically generated dimension text by retyping the asterisk.

To change the appearance of a dimension, you can assign it another dimension style.

14. On the Annotate tab in the Dimensioning group, select the Change Dimension tool.

15. In the tool settings, set the dimension style to DIM‐01.

16. Following the prompt, select the dimension element and accept with a data point.
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The dimension is changed.
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Pattern areas

There are three tools you can use to hatch or pattern areas:

 Hatch Area – To pattern an area with parallel lines in one direction.

 Crosshatch Area – To pattern an area with parallel lines in two directions.

 Pattern Area – To pattern an area with cells.

You can find these tools on the Annotate tab in the Patterns ribbon group.

1. Continuing in Annotating_Designs.dgn, open the Hatch and Pattern model.

2. Pattern the areas in this model according to the image below using the Hatch Area, Crosshatch Area, and Pattern Area tools.
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Try it out yourself first. Only read the following hints if you need help, or if you want to check if you did it right.

3. To hatch the first circle, select the Hatch Area tool and set the following:

(Method): Element

Spacing: 2

Annotation Scale: enabled (depressed)

Angle: 45

Drop Pattern: disabled

Associative Boundary: enabled

Snappable: disabled

4. Select the circle and accept with a data point.

Hint: The point where you accept also defines the pattern intersection point: the point through which a hatch line goes or where a pattern 
cell starts. So you can easily align different hatchings by snapping to the same point each time.

5. For the next figure, the block with the two circles, select the Union method.

6. First, select two of the three closed elements by clicking on them.

7. To be able to select more than two elements, hold the Ctrl key down and select the third element.

8. Following the prompt, accept with a data point.
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Hint: Another option is to select the three closed elements in advance, using Element Selection, and then hatch them with the Union 
method.

9. To crosshatch the next figure, the block with the three circles in it, select the Crosshatch Area tool and the Difference method.

10. In the tool settings, ensure both padlocks are closed, to crosshatch the area with perpendicular lines and the same spacing in both 
directions.

11. First, select the block.

12. Then select the first circle to subtract from the block and, with the Ctrl key pressed, select the other two circles.

13. Accept with a data point.

The area in the fourth figure, the circle with the line, will be patterned with a cell from a cell library.
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14. Select the Pattern Area tool with the Flood method.

15. In the tool settings, ensure that Pattern Definition is set to From Cell.

You will first attach a cell library.

16. Click the Browse Cell(s) button behind the Pattern field to open the Cell Library dialog.

17. In the Cell Library dialog, select File > Attach File.

18. Navigate to the \MSBasics\Standards\Cell folder in the course dataset and open the cell library geompa.cel.

19. In the cell list, select the cell that you want to use for patterning, for example, geom12.
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20. Click the Pattern button to make this cell the active pattern cell.

Hint: To view the size of the cell, you may also want to double-click it to temporarily activate the Place Active Cell tool. With the cell 
attached to the pointer, you can change the active scale in the tool settings and easily preview the result. As soon as you have found the 
correct scale value you can reset, return to the Pattern Area tool, and set the pattern scale to that value.

Now that you have found and set the pattern cell, you can continue with the Pattern Area tool.
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21. In the tool settings of the Pattern Area tool, set the remaining settings:

Scale: 1

Annotation Scale: enabled (depressed)

Row Spacing: 0

Column Spacing: 0

Angle: 0

Associative Boundary: enabled

22. Following the prompt, enter a data inside the area that you want to pattern. (So do not click the element boundary, like you did with the 
previous methods!)

The resulting area is highlighted.

23. Accept with a data point.

24. To pattern the first figure in the bottom row, you can use the Intersection or the Flood method.

25. For the second figure you can only use the Flood method, as this area is surrounded by lines, not by closed elements.
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In the third figure, the block and the text should be kept free from the patterning.

26. Select Pattern Area with the Flood method.

27. Expand the tool settings by clicking the downward arrow and set the following:.

Locate Interior Shapes: enabled

Locate Interior Text: enabled

Text Margin: 0.4

28. Then click within the area and accept with a data point.

In the last figure, the bottom half of the circle should be patterned, with only one pattern element. But the two blue lines are in the way! 
Solution: prior to using the Pattern Area tool, first select the elements that should be taken into account when the pattern area is being 
defined.

29. With the Element Selection tool, first select the circle and the red line.

30. Then select Pattern Area with the Flood method.

31. Click in the bottom half of the circle and accept with a data point.
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The complete lower half of the circle is patterned, disregarding the blue lines.

32. Clear the selection set.

Hint: So by selecting elements in advance, you can control which elements MicroStation should use to define the area, when using the 
Flood method.
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Change patternings

With the Change Pattern tool, you can change an existing hatching or patterning. You can:

 Apply the active color, line style, line weight.

 Apply the active pattern parameters (spacing, angle, scale, etc.).

 Redefine its pattern intersection point.

 Re-flood the pattern area.

 Apply the annotation scale to the pattern, or remove it from the pattern.

You can find the Change Pattern tool on the Annotate tab in the Patterns ribbon group.

1. Continue in Annotating_Designs.dgn, in the Hatch and Pattern model.

All the hatchings and patternings you created in the previous exercise are associated to the elements that define their boundary, because 
you enabled the Associative Boundary tool setting. So if one of those elements is modified, the patterning is automatically updated.

2. Try this out by moving or modifying some of the elements that define the pattern areas.

Let’s change the color, the spacing, and the angle of the hatching in the first circle. As usual, you change element attributes to the 
currently active attributes.

3. On the Home tab in the Attributes group, set the active color to color 1.

4. On the Annotate tab in the Patterns ribbon group, select Hatch Area and in the tool settings set the spacing to 4 and the angle to 90.

5. Select the Change Pattern tool in the same ribbon group.
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6. In the tool settings, enable the first two options: Attributes and Pattern Parameters.

7. Select the hatching in the circle.

The hatching is changed.

You will then change the scale of the patterning in the figure with the text from 1 to 2.

8. Select Pattern Area and set the scale to 2.

9. Select Change Pattern and ensure that only the option Pattern Parameters is enabled.

10. Select the patterning.

The pattern cells are scaled, while the color of the patterning stays the same, as the Attributes option was disabled.

Note: Using the Change Pattern tool, you can not replace the pattern cell with another cell.

Let’s move the patterning a bit, so that in the lower left corner it will start with a complete pattern cell.

11. Select Change Pattern and ensure that only the option Intersection Point is enabled.
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12. Select the patterning.

13. Following the prompt, define a new pattern intersection point by activating the Intersection snap mode and snapping to the intersection of 
the two red lines in the lower right corner.

Note that a complete cell is displayed now in the lower right corner.

Finally, you will add another element to a patterned area and re-flood the patterning.

14. Select Place Block and place a small block within the patterned area in the figure at the upper right.

15. Select Change Pattern and ensure that only the option Re‐Flood is enabled.

16. Select the patterning by clicking in the area where the patterning must remain.

The pattern area is regenerated and the block is kept free.

17. Close Annotating_Designs.dgn.
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Composing Designs and Drawings
The exercises in this workbook teach you how to attach references and control their display. You will also learn 
how to attach raster references and how to create a print composition using a sheet model.
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Attach a reference

A DGN file contains one or more models. When you place elements with MicroStation tools, the elements are added to 
the active model. A model can be either 2D or 3D and is stored as a separate object within a DGN file.

A reference is a model that is attached to and displayed along with the active model. 
References can be used for various purposes. You can attach, for example, a map or a floor plan to use as a 
background for your design. Or you can use references to attach multiple designs and details to a print sheet, thus 
creating a print composition.

You can reference models from the active DGN file or from other DGN files. You can also attach DWG files as 
references.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open MicroStation_Basics.dgn from the \MSBasics\dgn\11 - Composing Designs and Drawings folder in the course 
dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Streets model by double-clicking it in the list.

When working with references, you need to open the References dialog.
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5. On the Home tab in the Primary ribbon group, select the References icon.

This opens the References dialog.

You will attach the Hydrography model that is part of the active DGN file.

6. In the References dialog, click Attach Reference.

7. In the Attach Reference dialog, navigate to the \MSBasics\dgn\11 - Composing Designs and Drawings folder and select 
MicroStation_Basics.dgn.

8. Ensure that the attachment method is set to Interactive, otherwise the Reference Attachment Properties dialog will not appear.

9. Check the Save Relative Path check box.

Note: A reference attachment that identifies the location of the file by its full – or absolute – path is not portable across projects and 
networked systems. If the attached file is not found in the exact location, the attachment will be missing. The best way to ensure portability 
when attaching references is to enable Save Relative Path. This causes the relative path to the file to be saved with the attachment data 
in the DGN file, so the file can be more easily located.
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10. Click Open.

The Reference Attachment Properties dialog opens, allowing you to define various attachment settings.

11. At the top of the Reference Attachment Properties dialog, set the model to Hydrography.

This is the model to attach. 
The Hydrography model will be attached as a background to the Streets model. You will set the orientation to Coincident - World, to align 
the referenced model with the master model, and you will not scale the reference.
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12. Continuing in the Reference Attachment Properties dialog, set the following:

Orientation: Coincident ‐ World

Detail Scale: Full Size 1=1

True Scale: enabled

13. Click OK.
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The Hydrography model is attached to and exactly fits the Streets model. You can see the elements in both models now.

Note: An important attachment setting is the True Scale toggle. In case the working units differ between models, this option can be 
enabled to automatically correct this. For example, when the referenced model is created in feet and inches, and the active model in 
meters, MicroStation will adjust the scale so that the elements are the right size.
It is best practice to have True Scale always enabled when attaching references.
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Control the display of references

There are various ways to control the display of elements in a referenced model. You can:

 Turn the display of a complete reference on or off.

 Turn the display of levels in a reference on or off.

 Clip or mask a reference.

1. Continuing in MicroStation_Basics.dgn, in the Streets model, open the References dialog.

2. In the References dialog, click in the Display column to turn the display of the attached reference on or off.

Hint: If a column is not visible, right-click one of the column headers and check the column that you want to be displayed.

3. To control the display of levels in a reference, open the Level Display dialog by clicking the Level Display icon on the Home tab in the 
Primary group.

4. In the Level Display dialog, select the Hydrography model in the hierarchy tree.

The active model is at the top of the hierarchy tree, with the referenced models below it. When you click the active model or a referenced 
model, the levels contained in that model are listed in the dialog.
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5. Click once or twice on the Used column header to show all the used levels at the top of the list.

6. Click on the creek and the creek‐fill levels to turn them off.

The elements on those levels disappear.

7. Also turn off the river_lake_canal and the river‐fill levels.

8. Right-click on the level list and in the context menu select All On to turn all levels in the reference on again.

9. Close the dialog.

If you want to display only a certain part of a referenced model, you can clip the reference using an element or a fence.
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10. Select Place Block and create a block that includes part of the referenced Hydrography model.

11. In the References dialog, select the reference in the list and click the Clip Reference tool in the dialog’s toolbar.

12. In the tool settings, ensure that the method is set to Element and select the block.

The part of the referenced Hydrography model that is outside the block is covered.
To cover parts of the reference within the clip boundary, you can create one or more masks using the Clip Mask tool. You have to define 
the mask boundary with a fence.

13. Select the Place Fence tool in the Selection group on the Home tab.
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14. Place a fence to define the part of the reference that you want to cover.

15. In the References dialog, select the reference in the list, click the Mask Reference tool in the dialog’s toolbar, and accept with a data point.

16. Click Place Fence again to remove the fence.

Hint: To create a clip boundary or clip mask for multiple references, select those references in the list prior to creating the clip boundary or 
clip mask.

If a clipping boundary is created from an element, you can easily move or modify it afterwards by changing the element.

17. Select Modify Element (Home tab > Modify group) and move one of the vertices of the block to change the associated clipping boundary.

The clip mask remains unperturbed.
You can remove the clip boundary or clip masks one by one.

18. In the References dialog, select the reference that has clippings and click the Delete Clip tool in the dialog’s toolbar.
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The clip boundary and clip mask are highlighted.

19. Select the clip mask and accept with a data point.

The clip mask is removed. The remaining clip boundary is automatically selected.

20. Accept again to delete the clip boundary as well.

The complete Hydrography model is visible again.

Note: You can delete a clip boundary or clip mask only for one reference at a time, not for multiple references.
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Apply transparency and priority to a reference

When a reference contains filled areas, you can apply transparency or change its display priority to ensure that the 
elements in the other models remain visible.

1. Continue in MicroStation_Basics.dgn, in the Streets model.

First, you will make sure that transparency is displayed in view 1.

2. Click the View Attributes icon in the view control bar at the top of the view window.

3. In the View Attributes dialog, enable Transparency.

You will attach a second reference.

4. In the References dialog, click Attach Reference, ensure that the attachment method is set to Interactive, enable Save Relative Path, 
select MicroStation_Basics.dgn, and click Open.

5. In the Reference Attachment Properties dialog, set the following:

Model: Limit

Orientation: Coincident ‐ World

Detail Scale: Full Size 1=1

True Scale: enabled

6. Click OK.
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The Limit model is attached, but covers the elements in the Streets model and the Hydrography model.

You can solve this problem either by changing the display priority, or by making the Limit model transparent.

7. In the References dialog, right-click a column header and enable Transparency as well as Priority to add both columns to the dialog.

8. With the Limit model highlighted in the References dialog, click in the Transparency column and select 40.

The elements in the other two models show through the transparent limit boundary now.

9. Reset the transparency to 0 and set the priority to ‐1.

The referenced Limit model is displayed behind the other models now, as it has a lower priority than the elements in the active model and 
the other reference.
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Work with nested references

A nested reference is a reference that is attached to a reference. When you attach a reference, you can control how 
nested references are handled, or you can decide not to attach any nested references at all.
When live nesting is enabled, changes to nested reference attachments are reflected in any model to which their parent 
reference is attached.

1. Continuing in MicroStation_Basics.dgn, open the Models dialog and open the Hydrography model by double-clicking it.

You are going to attach a reference to this model.

2. In the References dialog, click Attach Reference, select MicroStation_Basics.dgn, and attach the Parks model, using the following 
attachment settings:

Orientation: Coincident ‐ World

Detail Scale: Full Size 1=1

True Scale: enabled

3. Return to the Streets model.

You can not see the elements in the nested Parks model yet. That’s because live nesting is off for the referenced Hydrography model.

4. In the References dialog, click the Show Hierarchy tool.
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5. In the hierarchy frame on the left, click the + preceding the file name to see the attached models.

6. Select the Hydrography model in the references list (not in the hierarchy frame!) and in the information panel below the list set Nested 
Attachments to Live Nesting and ensure that the Nesting Depth is set to 1.

The nesting depth determines how many ‘nesting levels’ deep you can view attached references. Set to 1, you can see the references 
that are directly attached to the Hydrography model. Set to 2, you will be able to see any references attached to those nested references 
as well.

The Parks model that you attached to the Hydrography model is now visible.
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Note: You can set the Nested Attachments and Nesting Depth settings when attaching a reference, or change these settings afterwards, 
as you just did.

7. In the hierarchy frame in the References dialog, click the + preceding the Hydrography model.

The nested Parks reference is now also displayed in the hierarchy tree.

8. In the hierarchy frame, select the Hydrography model.

In the right frame, the Hydrography model’s references are listed now.

9. Turn off the display of the nested Parks reference by clicking the check mark in the Display column.
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Exchange to or activate a reference

As a rule, you can not change elements in a referenced model. You can only make changes to the active model. 
But there are two ways to easily switch between the active model and a referenced model.

 Activate a reference – To temporarily activate a referenced model for in-place editing, while the active model and 
other referenced models remain visible. This method is recommended, because it allows you to maintain the 
current view orientation and to snap to elements in the active model.

 Exchange to a reference – To close the current model and open the selected reference, maintaining the same view 
orientation. This method may be preferable when you want to focus exclusively on the referenced model.

1. Continue in MicroStation_Basics.dgn, in the Streets model.

First, you will exchange to a reference.

2. In the References dialog, right-click the referenced Hydrography model in the list and select Exchange in the context menu.

The Hydrography model opens and the Streets model and Limits model are not displayed anymore.

3. Select the Element Selection tool and expand the tool settings.

4. In the tool settings, on the Level tab, select the level river‐fill.

The elements on this level are selected and highlighted, and the level is moved to the top of the list.
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5. On the Home tab in the Attributes group, set the active color to 111, a dark turquoise.

6. Click somewhere in the view, to clear the selection set.

The river fill is now dark turquoise.

7. Click the Previous Model icon at the lower left of the application window to return to the Streets model.

The change you made to the reference is seen immediately.

Note: This is also the case when a reference is ‘owned’ and changed by someone else. When a reference is changed while you are using 
it, you can right-click it and select Reload to update its contents.

Let’s see what happens when you activate a reference instead of exchanging to it.

8. Right-click the Hydrography model in the References dialog and select Activate in the context menu.

This time, the Hydrography model is opened while the Streets model and the Limit model remain visible, but in a special color.

Hint: You can change this override color as follows. Click the File tab, on the backstage select Settings > User > Preferences, and change 
the Active Reference Override Color in the category Reference.

9. Move the pointer over the elements that are displayed and note that only the elements in the activated reference can be selected. The 
elements in the other models are locked.
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Let’s review the information in the References dialog.

10. Note the dot in the Activate Status column of the Hydrography reference, indicating that this reference is activated.

11. Use the same method as described earlier in this exercise to change the color of the elements on the level river‐fill to 7.

To return to editing the active model, you have to deactivate the reference.

12. Right-press anywhere in the view and in the context menu select Deactivate Hydrography (or click once on the dot in the References 
dialog).

The Streets model is active again.
The dot is changed into a check mark. A check mark indicates that the reference is locked for editing in another session. 

Note: Currently, the check mark is gray and the reference can not be unlocked, because the referenced model is in the same file as the 
active model.
But also when the reference is in another file and you deactivate it, it remains locked. The reason that deactivating a reference does not 
automatically release the lock, is that once the lock is relinquished it is not possible to undo changes. 
Imagine you are actively working on a set of files. As you activate various references successively, you acquire their locks. You can hold 
these locks until you decide you are ready to release them (or until you close the file).
To release the write lock on a deactivated reference, click the (black) check mark in the Activate Status column. Or deactivate the 
reference and release the lock in one action by double-clicking in the Activate Status column.

13. Close the References dialog.

14. Close MicroStation_Basics.dgn.
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Attach a raster image

Using Raster Manager you can attach raster images of various formats, from monochrome to full color. You can modify 
the location, display order, and various other settings of previously attached raster image files. When a raster 
attachment is modified with Raster Manager, no changes are made to the original file, just to its attachment information 
in the DGN file.

1. Open Raster.dgn from the \MSBasics\dgn\11 - Composing Designs and Drawings folder in the course dataset.

2. Open the Display Priority model.

To attach a raster image, you will not use the References dialog, but the Raster Manager dialog.

3. Open the Raster Manager dialog by clicking the Raster Manager icon on the Home tab in the Primary ribbon group.

4. In the Raster Manager dialog, click the Attach icon.
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5. In the Attach Raster Reference dialog, navigate to the \MSBasics\dgn\11 - Composing Designs and Drawings folder and select 
satellit.itiff.

6. Enable Place Interactively and click Open.

Note: Enabling Place Interactively allows you to position the raster image yourself. If Place Interactively is disabled, the raster image is 
placed automatically, based on the image’s own positioning information.

The Raster Attachment Options dialog opens. The options in this dialog allow you to set various attributes of the raster attachment, such 
as the level it is placed on, the symbology of the raster border, or in which views and which plane it is displayed.

7. In the Raster Attachment Options dialog, on the Image panel, key-in Plane change as the Description.

This will make it easier for you to recognize the raster attachment.

8. On the Display Print panel, ensure that the image will be placed in the Background plane.
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9. Click Attach and – following the prompt – enter two diagonal data points to place the image in the design.

Note: When attaching a raster image to a 2D model, the raster can be placed in different planes.

 Design – The raster shares the same space as design elements and you can use the display priority to define the display order.

 Background – The raster will always be behind any design elements.

 Foreground – The raster will always be in front of any design elements.
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Control the display order of raster images and design elements

You can control the display order of raster images by changing their plane or – when they are in the Design plane – by 
changing their display priority.

1. Continue in Raster.dgn, in the Display Priority model.

You will add a design element to the model.

2. On the Home tab in the Placement ribbon group, select Place Bock with the following tool settings:

Method: Orthogonal

Area: Solid

Fill Type: Opaque

Fill Color: 7

3. Place the block so that it overlaps part of the raster image.

The raster image is displayed behind the block, because it is on the Background plane.
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4. In the Raster Manager, click the little icon to the left of the newly attached raster reference, in the menu that opens select Foreground, 
and click OK.

The raster image is moved to the Foreground plane and now covers the block.

5. Click the plane icon again and select Design and OK to move the raster image to the Design plane.

Within the Design plane, the order of raster images and design elements are determined by their display priority.

6. Select the block with the Element Selection tool and on the Home tab in the Attributes group, set the Priority to ‐100.

7. Clear the selection set.

The block is now displayed behind the raster image.

8. Right-click one of the column headers in the Raster Manager dialog and enable the Display Priority column.
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9. Change the display priority of the raster image to ‐200.

Again note the change in the display order.

Note: The same as with vector references, you can clip raster references, or scale, move, mirror, or rotate them, using the tools in the 
Raster Manager dialog.
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Attach a PDF document

You can attach an Adobe PDF file in the same way you attach any other raster image. When you have a multi-page 
PDF, you must choose a single page for attachment. In addition, you can control the display of specific layers in an 
attached PDF.

1. Continuing in Raster.dgn, open the PDF Reference model.

You will detach the previously attached PDF and attach it yourself.

2. In the Raster Manager dialog, right-click 2DExample.pdf and in the context menu select Detach.

3. Click the Attach icon.

4. In the Attach Raster Reference dialog, navigate to the \MSBasics\dgn\11 - Composing Designs and Drawings folder and select 
2DExample.pdf.

5. Enable Place Interactively and click Open.

6. Without changing anything in the Raster Attachment Options dialog, click Attach and enter two diagonal data points to attach the PDF to 
the active model.
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Hint: A PDF may also contain geographical coordinates information, allowing you to attach it at its exact predefined location. In that case, 
disable Place Interactively.

7. Zoom in on the image.

8. In the Raster Manager dialog, right-click 2DExample.pdf and in the context menu select Layers....

9. In the Layer Display dialog, turn off a few layers, for example, (none) (Markers) and orange numbers (Adresses).

10. Click Apply or OK

The contents of those PDF layers are not displayed anymore.

11. Close Raster.dgn.
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Create a sheet model with a border

In MicroStation, there are three different types of models.

 Design model – Contains the elements that represent what is built, drawn at full scale (1:1). A design model can be 
2D or 3D. To create a more complex design, multiple design models can be referenced to each other (1:1), thus 
forming a design composition.

 Sheet model – Is used to define printed output, ready for printing or publishing. A sheet model is always 2D and 
best practice is to draw it at full paper size (1:1). Design models are attached as references and scaled to fit the 
sheet. Each reference in a sheet composition can have its own attachment scale, allowing you to create a print 
sheet with multiple scales.

 Drawing model – Is always 2D and stores a subset of a 2D or 3D design model or design composition. It can be 
used to compose a drawing with global annotation, allowing you to separate the annotations from the geometry. 
Using drawing models is optional.

In this exercise, you will create a sheet model with a border. 

1. Open MicroStation_Basics.dgn from the \MSBasics\dgn\11 - Composing Designs and Drawings folder.

2. Open the Models dialog and open the Annotating Designs sheet model (not the Annotating Designs Challenges design model!).

3. In the Models dialog, click the Create a new model tool.

4. Set the following in the Create Model dialog:

Type: Sheet + 2D

Name: Print Sheet

Annotation Scale: Full Size 1=1

Show Sheet Boundary: enabled

Size: ISO A1
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A new sheet model is created and opened. The sheet boundary indicates the size of the sheet: a full-sized A1 paper sheet.
Before continuing, let’s check if the drawing units are set correctly. These are derived from the previous model, as you did not use a seed 
model to create the new sheet model.

5. In the Models dialog, right-click the new Print Sheet model and in the context menu select Properties.
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6. In the Properties dialog, on the Working Units panel, check if the Master Unit is set to Millimeters. If not, change it. 

You will attach a border as a reference.

7. Open the References dialog, click Attach Reference, and select A1‐border.dgn (in the \MSBasics\dgn\11 - Composing Designs and 
Drawings folder).

8. In the Reference Attachment Settings dialog, set the following and click OK:

Model: Default (this is a full size A1 border model)

Orientation: Coincident ‐ World

Detail Scale: Full Size 1=1

True Scale: enabled
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The border model is correctly referenced to the sheet model.
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Create a print composition

Using the sheet model you created in the previous exercise, you will attach multiple design models with different scales, 
to create a print composition of a 3D building design. In addition, you will attach a raster image.

1. Continue in MicroStation_Basics.dgn, in the newly created Print Sheet model.

First, you will attach the front view of a 3D building model.

2. In the References dialog, click Attach Reference and select BSI300AE9‐Atrium.dgn (in the \\MSBasics\dgn\11 - Composing Designs and 
Drawings folder).

3. In the Reference Attachment Settings dialog, set the following:

Model: Composite

Orientation: Standard Views > Front

Detail Scale: 1:200

Nested Attachments: Live Nesting

Nesting Depth: 4

Drawing Boundary: (None)

True Scale: enabled

You can set the Detail Scale simply to the scale that the design model should be displayed and printed at. The Scale (Master:Ref) is then 
automatically calculated from the detail scale and the sheet’s annotation scale. Because in this example the sheet is at full paper size and 
the sheet’s annotation scale is set to Full Size 1=1, the Scale (Master:Ref) is also set to 1:200.

As you are not using one of the Coincident orientations this time, you can position the reference on the sheet yourself.
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4. Click OK and enter a data point to place the reference at the top of the sheet.

If necessary, you can move, scale or rotate the reference after it has been attached, using the tools in the References dialog’s toolbar. 
When using a reference as a background for your design, those kinds of manipulations usually are not allowed, because it would disrupt 
the alignment of both models. But when attaching a reference to create a print composition, you can place the referenced model 
wherever you prefer, with a scale that best suits the purpose.

Next, you will attach the floor plan of the building, using the same model, but with a different orientation and scale.

5. In the References dialog, attach BSI300AE9‐Atrium.dgn again, with the following attachment settings:

Model: Composite

Orientation: Standard Views > Top

Detail Scale: 1:100

Nested Attachments: Live Nesting

Nesting Depth: 4

Drawing Boundary: (None)

True Scale: enabled
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6. Click OK and enter a data point to place the reference on the sheet, below the front view.

The floor plan may be a bit too large for this print sheet, so let’s change the scale.

7. In the References dialog, select the reference that is attached with the Standard Top orientation.

8. Click in the second Scale field below the references list, change the value to 200, and press the Tab key.
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The floor plan is scaled down to 1:200.

9. If necessary, move the floor plan reference using the Move Reference tool, so that it is below the front view of the building.

The design of the rest rooms unit is in a separate model that you will attach with scale 1:50.

10. In the References dialog, attach BSI300AE9‐Atrium.dgn again, with the following attachment settings:

Model: Restrooms

Orientation: Standard Views > Top

Detail Scale: 1:50

Nested Attachments: Live Nesting

Nesting Depth: 4

Drawing Boundary: (None)

True Scale: enabled



Copyright © 2016 Bentley Systems, Incorporated 36DO NOT DISTRIBUTE - Printing for student use is permitted

11. Click OK and enter a data point to place the reference to the right of the front view.

Finally, you will attach a raster file, to show a rendered image of the complete building.

12. Open the Raster Manager dialog and attach Visualization‐Master.jpg (in the \MSBasics\dgn\11 - Composing Designs and Drawings 
folder) interactively.

13. Save and close MicroStation_Basics.dgn.
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Printing and Publishing
This workbook contains exercises to practice how to print a sheet model with a print composition, and how to 
print directly from a design model.
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Print a sheet model with a print composition to PDF

In this exercise, you will print a print composition in a sheet model to a PDF file.
The steps to create a single-sheet print from MicroStation are as follows.

 Prepare a model for printing – Best practice is to create a print composition in a sheet model (as explained in the 
practice workbook Composing Designs and Drawings). That allows you to print multiple models on one sheet, with 
different scales. 
Another option is to print directly from a design model, one model at a time. In that case, you have to place a border 
and define the print area with a fence.
With either method, ensure that everything that should not be printed is not displayed (levels, view attributes, 
references).

 Set the printing parameters – In the Print dialog, select a print style, which is a named collection of print definition 
properties. Or select a printer and manually set the printing parameters, such as the sheet size, scale, and output 
color mode.

 Create printed output – You can print directly to a Windows system printer, or save the print to a file.

1. Start MicroStation CONNECT Edition and on the work page set the following:

Workspace: BentleyCONNECTTraining

Workset: MSBasics

2. Click Browse and open Print_Composition.dgn from the \MSBasics\dgn\12 - Printing and Publishing folder in the course dataset.

By default the dataset is installed at C:\BentleyCONNECTTraining\WorkSets\.

3. Open the Models dialog by clicking the Models icon on the Home tab in the Primary group.

4. Open the Print Sheet model by double-clicking it in the list.
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This sheet model has the size of a full-sized A1 paper sheet.

5. Open the References dialog and review the attachment scales of the attached references by highlighting them in the list one by one.

An A1 border is attached at full scale 1:1. Two design models are attached with scale 1:200 and one with scale 1:50. 
In addition, a raster image is attached.

6. In the Quick Acces Toolbar click the Print icon.

This opens the Print dialog.

First, you will select a printer and set the paper size and orientation. 
You can work with either of two types of printers: those controlled via the Windows system and those controlled via a Bentley driver.

 When selecting Windows printer or one of the Windows options, the printer driver configuration file printer.pltcfg is used to print 
directly to the default Windows system printer or another network printer.

 When selecting one of the Bentley drivers, you can select the desired printer driver configuration file.
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7. Open the printer menu and select PDF to open the Bentley printer driver configuration file pdf.pltcfg.

8. Set the paper size to ISO A1 and the orientation to Landscape.

Next you can set the area to print.
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In this case, the area is set to Sheet because you are printing a sheet model that has a sheet boundary displayed.

When you print a design model, the area is set to View and the active view number will be reflected. If there is a fence in the model, the 
area is set to Fence. You can change the print area at any time using the Area option.

9. Change the Color option to Grayscale. 

The print preview updates accordingly.

10. Reset the output color mode to True Color.



Copyright © 2016 Bentley Systems, Incorporated 6DO NOT DISTRIBUTE - Printing for student use is permitted

Before setting the print scale and position, you will first check the printer units.

11. In the Print dialog, select Settings > Units > mm. 

This sets the printer units to be the same as the model’s master units: millimeters. 
The paper size is displayed in millimeters now: 841 x 594 mm.

Because the sheet boundary in the sheet model has exactly the same size as the selected paper size, the scale is set to 1, meaning that 
1 millimeter in the model equals 1 millimeter on paper. 
As the sheet model is not scaled at printing time, this means that the referenced design models will be printed with their respective 
attachment scales. 

12. If the scale is not set to 1, click the Maximize button or manually set the scale to 1.

If you set the scale to a higher value, the model in the preview – and on paper, of course – becomes smaller.
If you set the scale to a lower value, the model is scaled less and only a part of the model will fit on the selected paper sheet.

Before finally printing the sheet model to a PDF file, you will ensure that in the resulting PDF the display of levels and references can be 
toggled on and off. To make that possible, you will enable a specific setting in the printer driver configuration file pdf.pltcfg.

13. In the Print dialog, select File > Edit Printer Driver Configuration.

14. On the Base Properties tab, open the Driver Properties panel.
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15. Turn on the Enable Optional Content setting.

16. In the Printer Driver Configuration dialog, select File > Save as and save the printer driver configuration file pdf_training.pltcfg.

17. Close the dialog.

18. In the Print dialog, select pdf_training.pltcfg as the printer driver configuration file to use.

Then you can print the sheet model to a PDF file.

19. In the Print dialog, click the Print icon.

20. In the Save Print As dialog, navigate to a folder where you want to save the output PDF file, for example to the \MSBasics\out folder.

21. Save the PDF file as Print_Composition‐Print Sheet‐000.pdf (file name-model name-sequence number).

22. If Adobe Reader is installed on your system, open the PDF file.

23. In Adobe Reader, click the Layers icon to display the Layers tab.

24. Expand Print_Composition.dgn<Print Sheet> > References > BSI300AE9-Atrium.dgn<Restrooms> > Levels.
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25. Click the eye icon that precedes the A‐G42‐G‐FittRest and A‐G49‐G‐FittOthr levels in this reference, to turn these levels off.

26. Close Adobe Reader.

27. Close Print_Composition.dgn.

So, best practice to create printed output is to create a sheet model at full paper size (1:1). Then attach the design models as references 
and scale them to fit the sheet. Each reference in a sheet composition can have its own attachment scale, allowing you to create a print 
sheet with multiple scales. Finally, print the sheet model with a print scale set to 1. Each referenced design model is then printed with its 
own attachment scale.
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Print directly from a design model

Instead of printing a print composition in a sheet model – the preferred method – it is also possible to print directly from 
a design model. In that case, you have to place a border and define the print area with a fence.

1. Open BSI300AE9‐Atrium.dgn from the \MSBasics\dgn\12 - Printing and Publishing dataset folder.

2. Open the Composite model.

This is a 3D design model.

3. In the view control bar, press the View Rotation icon and in the menu select Top View.

4. Fit the view and then zoom out a bit.

This design model is created at full size 1=1, just like every design model. To be able to print it on an A1 paper sheet, you have to scale it 
down with a scale factor 1:100.
But first, you will attach a border. Because you intend to print the design with scale 1:100, the border has to be attached with a reversed 
scale factor 100:1.

5. In the References dialog, click Attach Reference and select A1‐border.dgn (in the \MSBasics\dgn\12 - Printing and Publishing folder).

6. In the Reference Attachment Settings dialog, set the following:

Model: Default (this is a full size A1 border model)
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Orientation: Standard Views > Top

Scale (Master:Ref): 100:1

Nested Attachments: No Nesting

True Scale: enabled

7. Click OK and enter a data point to place the border around the design.

The easiest way to define the print area in a design model is by placing a fence.

8. Select Place Fence in the main tool bar of the Tasks dialog and set the following:

Fence Type: Block

Fence Mode: Inside

9. Place a fence by snapping to the lower left corner of the dotted rectangle around the border and then snapping to the opposite corner.

Hint: Keep both the Ctrl and the Shift key pressed to activate AccuSnap while placing the fence.
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10. Click the Print icon in the Quick Acces Toolbar.

The print area is automatically set to Fence, because a fence is available in the model.

11. Set the printer to pdf.pltcfg (or to pdf_training.pltcfg).

12. Set the paper size to ISO A1 and make sure the orientation is set to Landscape.

13. Click the Maximize button, to maximize the size of the print.

If you defined the fence accurately, the scale is automatically set to 100. 
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14. If not, manually set the scale to 100.

So, presuming that the printer units are still set to millimeters (from the previous exercise), 100 millimeters in the model will be printed to 
1 millimeter on paper, meaning that the design model is printed with scale 1:100.

15. In the Print dialog, click the Print icon.

16. Navigate to a folder where you want to save the output PDF file, for example to the \MSBasics\out folder.

17. Save the PDF file as BSI300AE9‐Atrium‐Composite‐000.pdf.

18. If Adobe Reader is installed on your system, view the contents of the PDF file.
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19. Close Adobe Reader.

20. Close BSI300AE9‐Atrium.dgn.
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