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Manipulating a Group of Elements

Qﬁm

This project exercise provides systematic instructions for creating the design shown in Fig-
The intent is to guide you in applying Element Selection and Fence
manipulations.

ure P6-I.
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Completed project design

Note: The text and dimensions placed on the structure and members are not part of

this project. They are included in Figure P6—1 as an aid to drawing the design.
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PREPARE THE DESIGN FILE

This procedure starts MicroStation, creates a design file, and enters the initial

settings.

STEP I:
STEP 2:
STEP 3:

STEP 5:
STEP 6:

STEP 7:

Note: As you complete each step in the project procedures, place a check mark by the
step to help you keep up with where you are in the project.

Invoke MicroStation program.
Create a new design file named CH6.DGN using the seed2d seed file.
In the Design File dialog box:

Make sure the Working Unit is set to Feet for Master Unit and Inches for the
Sub Unit.

Set the Grid Master to 0.5, the Grid Reference to 2, and turn the Grid lock.

Select Settings > Level > Manager to open the Level Manager settings box
and create the following level names and assign the properties:

Objects — Color to green, Line Style to (solid line), and Line Weight to 2.
Structure — Color to blue, Line Style to 0 (Solid line), and Line Weight to 2.
Title Block — Color to red, Line Style to 0 (solid line), and Line Weight to 2.
Invoke AccuDraw from the Primary Tool box.

Open the AccuDraw settings box from the Settings drop-down menu, and adjust
the values as follows:

Unit Roundoff Distance$: $Set to 0.5 and turn the check box ON.
Unit Roundoff Angle$: $Set to 90.000 and turn the check box ON.
Coordinate System: Set the Rotation to Top and the Type to Rectangular.

Operation: Set the check boxes for Floating Origin and Smart Key-ins to ON;
and for Context Sensitivity and Auto Point Placement, set them to OFF.

Using Figure P61 as a guide, draw the border and title block on level Title Block.

Replace “SCHOOL NAME” with your school or company name, or make up
a name.

Place your name to the right of “NAME.”

Place today’s date to the right of “DATE.”

DRAW THE FIRST I-BEAM
This procedure describes the steps required to draw the I-beam shown in Figure

P6-2.
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Figure P6-2 Draw the first column

STEP I: If View Window 2 is not open, select the Views submenu from the Window
drop-down menu, and turn on View Window 2.

STEP 2: From the Window drop-down menu, select the Cascade option.
STEP 3: Fit View Window I.

STEP 4: Set the Active Level to Objects.

STEP 5: Invoke Save Settings from the File drop-down menu.

STEP 6: Invoke the Place Line tool from the Linear Elements tool box.

MicroStation prompts:

Place Line > Enter first point

Keypoint snap to the lower left corner of the border block, type O to release the
AccuDraw origin, and drag the cursor so the X-axis is set to 10.0000 and the Y-
axis is set to 12.5. Click the Data button to locate the start of the bottom I-beam
line.

Place Line > Enter endpoint

Drag the cursor so the X-axis is set to 1.0000 and the Y-axis is set to 0.0000. Click
the Data button to complete the line.

Place Line > Enter endpoint (Click the Reset button.)

STEP 7: In View Window |, invoke the Window Area tool, then, in the Tool Settings
window, set the Apply to Window option to 2.

MicroStation prompts:

Window Area > Define first corner point

Place a data point about 2 feet above and to the left of the I-beam line that was
just completed.
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Window Area > Define opposite corner point
Drag the dynamic rectangle below and to the right of the line, then place a data
point to place the view area in View Window 2.)
STEP 8: Invoke Save Settings from the File drop-down menu.

STEP 9: In View Window 2, use Center Snap to place a vertical |’-long line centered
above the line you just drew, then place a I’-long top horizontal line centered
above the vertical line, as shown in Figure P6-2.

SELECT AND GROUP THE I-BEAM LINES

This procedure groups the three lines forming the I-beam so they can be manipu-
lated as one element.

STEP |: Invoke the Element Selection tool from the Main tool tool, and then select the
Block Method and New Mode in the Tool Settings window.
MicroStation prompts:
Element Selection > Place Shape for elements to add to set
Position the cursor above and to the left of the I-beam, then press and hold down

the Data button while you drag the Selection rectangle around the I-beam. Release
the Data button to select the three lines.

STEP 2: Invoke the Group option from the Edit drop-down menu. MicroStation creates
a group of the three selected lines. Click the Data button to remove the
selection.

CREATE THE TWO ROWS OF COLUMNS

This procedure uses the Copy Element, Rotate Copy, Place Fence Block, and
Copy Fence Contents tools with AccuDraw to create the two rows of three I-
beams each, as shown in Figure P6-3.
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Figure P6-3 Two rows of |-beams

STEP I: Click the title bar of View Window | to return focus to it.

STEP 2: Invoke the Copy Element tool from the Manipulate tool box, then turn the
Make Copy button ON in the Tool Settings window.

MicroStation prompts:

Copy Element > Identify element

Select the I-beam, type Y to lock the AccuDraw Y axis at 0.0000, then drag the
manipulation pointer right to AccuDraw coordinate X = 24. Click the Data button
to make the first copy in the bottom row.

Copy Element > Accept/Reject (select next input)

Type Y to lock the AccuDraw Y axis at 0.0000, then drag the manipulation point-
er to the right to X = 16. Click the Data button to complete the bottom row, as
shown in Figure P6—4.

Copy Element > Accept/Reject (select next input)
Click the Reset button to terminate the tool sequence.

STEP 3: In View Window 1, define a small Window Area, to be placed in View Window
2, around the right-most I-beam.

STEP 4: Click the title bar or border of View Window 2 to return focus to it.
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Figure P6—-4  Bottom row after the |-beam is copied two times

STEP 5: Invoke the Rotate tool from the Manipulate tool box, then, in the Tool Settings
window, set the Method to Active Angle, set the Active Angle to 90, and set
the check box for Make Copy to OFF.

MicroStation prompts:
Rotate Element > Identify element

Identify the I-beam.

Rotate Element > Enter pivot point (point to rotate about)

Click the Data button in the center of the I-beam’s vertical line to pivot the I-
beam about its center point, then click the Reset button.

STEP 6: Click the title bar or border of View Window | to return focus to it.

STEP 7: Invoke the Place Fence tool from the Fence tool box, then, in the Tool Settings
window, set the Fence Type to Block and the Fence Mode to Inside.

MicroStation prompts:
Place a Fence Block > Enter first point

Place a data point above and to the left of the left-most I-beam.

Place a Fence Block > Enter opposite corner

Drag the dynamic fence image around the three I-beams, then place a data point
to complete the fence.

STEP 8: Invoke the Copy tool from the Manipulate tool box, then, in the Tool Settings
window, set the check boxes for Make Copy and Use Fence to ON.
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MicroStation prompts:
Copy Fence Contents > Enter first point

Place a data point somewhere near the bottom of the view.

Copy Fence Contents > Enter point to define distance and direction

Type X to lock the AccuDraw X axis at 0.0000, then drag the manipulation point-
er up to Y = 24. Click the Data button to create the top I-beam row, as shown in
Figure P6—4.

Copy Fence Contents > Enter point to define distance and direction
Click the Reset button to terminate the tool sequence.
STEP 9: Invoke the Place Fence tool again to remove the fence.

STEP 10: Invoke Save Settings from the File drop-down menu.

DRAW THE OUTSIDE STRUCTURAL MEMBERS

This procedure places a Block element for the outside structural members, then
uses the Partial Delete tool to cut away the parts of the Block that overlap the I-
beams, as shown in Figure P6-5.
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Figure P6-5 |-beams and outside structural members

STEP I: Set the Active Level to Structure.

STEP 2: In View Window I, place a Block element with its lower left corner in the center
of the lower left I-beam and its upper-right corner in the center of the upper-
right I-beam, as shown in Figure P6-6.
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STEP 3: In View Window |, define a small Window Area, to be placed in View Window
2, around the lower-right I-beam.

STRUCTURAL STEEL HAHE
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Figure P6-6 Result of placing a block for the outside structural members

STEP 4: Focus on View Window 2, then invoke the Partial Delete tool from the Modify
tool box.

MicroStation prompts:

Delete Part of Element > Select start point for partial delete

Select the block one Grid point to the left of the I-beam in View Window 2.

Delete Part of Element > Select direction of partial delete

Drag the manipulation pointer a short distance toward the I-beam, and click the
Data button.

Delete Part of Element > Select end point of partial delete

Drag the manipulation point to one Grid point above the I-beam, and place a data
point to complete the partial delete, as shown in Figure P6-7.
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Figure P6-7 Amount of block to delete partially over each I-beam

STEP 5: Focus on View Window |, then define a small Window Area, to be placed in
View Window 2, around the upper-right |-beam.

STEP 6: Focus on View Window 2, then invoke the Delete part of the Element tool from
the Modify tool box.

MicroStation prompts:
Delete Part of Element > Select start point for partial delete

Select the line one Grid point below the I-beam.

Delete Part of Element > Select end point of partial delete

Drag the manipulation pointer to one Grid point to the left of the I-beam, and
place a data point to complete the partial delete.

STEP 7: Repeat Steps 5 and 6 for the other four I-beams.

DRAW THE INTERIOR STRUCTURAL MEMBERS

This procedure uses the Move Parallel and Extend Element to Intersection tools
to draw the interior structural Members as shown in Figure P6—8.
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Figure P6-8 Completed interior structure members

STEP I: Focus on View Window |.

STEP 2: Invoke the Move Parallel tool from the Manipulate tool box, then, in the Tool
Settings window, turn the check boxes for Distance and Make Copy to ON,
and key-in 12 in the Distance edit field.

MicroStation prompts:
Copy Parallel by Key-in > Identify element

Select the left vertical line.

Copy Parallel by Key-in > Accept/Reject (select next input)

Move the manipulation pointer to the right of the element, and click the Data
button two times to place two parallel copies of the line, as shown in Figure P6-9.
Click the Reset button.

Copy Parallel by Key-in > Accept/Reject (select next input)

Click the Reset button.
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Figure P6-9 Place two parallel copies of the left vertical line, 12’ apart

STEP 3: Make two parallel copies of the top left horizontal line, each 8’ apart below the
line, as shown in Figure P6-10.

STRUCTURAL STEEL PLAKE:
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Figure P6-10 Place two parallel copies of the top left horizontal line, 8 apart below
the line

STEP 4: Make three parallel copies of the top right horizontal line, each 6’ apart below
the line, as shown in Figure Pé—11.
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Figure P6-11 Place three parallel copies of the top right horizontal line, each 6’ apart

below the line

STEP 5: Invoke Save Settings from the File drop-down menu.

STEP 6: Refer to the Project Exercise in Chapter 9 for placing text and dimensioning.
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DRAWING EXERCISES 6-1 THROUGH 6-5

Use the following table to set up the design files for Exercises 6—I through 6-3.

SETTING VALUE

Seed File seed2d.dgn
Working Units Master Units: Inches and Sub Units: Inches
Grid Master = .1, Reference = 10, GRID Lock ON

FLANGE GASKET

N\ 7\ 7\ W7\ 7
QI\ DX IRDX 7 /\g
4 : : : >
R0.25
] 0.75(TYP.) Lo oo ~l/_mn:.)
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5.00 © 3.00 “G¥) (1YR.)
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A L 1.00 (TYP.) ) ((*—R 0.50
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ROTARY PRESSURE JOINT

T 30°
TYP.4
R 0.500
TYP. 2
Z4.000
R 0O.156
@3.375 TYP.B
R0.562
TYP. 2 D4.625
TYPICAL
R 0.250
TYP. 2
OKD o
T 1.400
R 1.000
TYPICAL
@2.250
33.875 R 0.100
TYP.6
R 0.250 R0.312
TYP. 4 TYP.3
1.000
ROTARY PRESSURE JOINT
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Use the following table to set up the design files for Exercises 6—4 and 6-5.

SETTING

Seed File
Working Units
Grid

VALUE

seed2d.dgn
Master Units: Feet and Sub Units: Inches
Master = 0.5, Reference = 24, GRID Lock ON

LEADED GLASS DESIGN

2" (TYP.)

10111 5

LEADED GLASS DESIGN
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CUSTOM DOORS
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