
7
Placing Text, Data Fields and Tags

PROJECT EXERCISE

This project exercise provides step-by-step instructions for creating the circuit board drill-
ing diagram and hole locations table shown in Figure P7–1. The project provides practice
for placing and filling in Text Nodes and Data Fields, and for placing text elements.

Notes: Dimensions are shown in some of the instruction pictures in this project only
as an aid to drawing the design, and are not drawn as part of this project.

As you complete each step in the project procedures, place a check mark by the step
to help you keep up with where you are in the project.

Figure P7–1 Completed project design

PREPARE THE DESIGN FILE

This procedure starts MicroStation, creates a design file and enters the initial
settings.
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STEP 1: Invoke MicroStation and create a new design file named CH7.DGN using the
seed2d.dgn seed file.

STEP 2: In the Design File dialog box, set the Working Units Master Unit and Sub
Unit to ‘‘Inches’’ and the Coordinates Format to Master Units.

STEP 3: If focus is not on View Window 1, focus on it by clicking the Data button on its
title bar or border.

STEP 4: Select Element > Text Style and, in the Text Styles settings box, select File >
New.

STEP 5: Click the General tab and enter the settings shown in Figure P7–2.

Figure P7–2 Initial Text settings

STEP 6: Select File > Save to save the new text style.

STEP 7: Create another text style. In the Style Name field, key-in CH 7 Left Center;
in the Parent Style Name menu, select CH 7 Center Center; and in the
Justification menu, select the Left Center option.

Note: Setting the CH 7 Center Center style as the parent of this new, child style
causes the child to assume all the settings of the parent style.

STEP 8: Select File > Save to save the new text style.

STEP 9: In the Text Styles column on the left side of the Text Styles settings box, select
CH 7 Center Center to make it the default text style for text placement.

STEP 10: Turn on AccuDraw.
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STEP 11: Select Settings > AccuDraw to open the AccuDraw settings box and make the
following AccuDraw setting on the three tabs:

◗ On the Operation tab, turn the Auto Point Placement check box OFF,
and turn the other check boxes ON.

◗ On the Display tab, turn OFF the Delayed Update and Show Negative
Angles check boxes and turn ON the Pop-up Confirmations check box.

◗ On the Coordinates tab, set the Coordinate System Rotation to View and
the Type to Rectangular, lock the Unit Roundoff Distance at 0.1 inch, and
turn ON the Indexing Axis and Distance check boxes.

STEP 12: Select Settings > Snaps > AccuSnap and, on the AccuDraw settings box
General tab, turn the Enable AccuSnap check box ON.

STEP 13: Select Settings > Level > Manager and create the following level names:

◗ Border

◗ Object

STEP 14: Select File > Save Settings.

DRAW THE BORDER AND TITLE BLOCK

This procedure draws the border and title block.

STEP 1: Set the Active Level to Border, the Active Color to white (0), the Active Line
Style to 0 (solid), and the Active Line Weight to 1.

STEP 2: Using Figure P7–3 as a guide, draw the border and title block.

STEP 3: Fit View Window 1.

Figure P7–3 Dimensions for drawing the border and title block
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PLACE TEXT NODES ON THE TITLE BLOCK

This procedure places empty Text Nodes in the title block area.

STEP 1: Select Settings > View Attributes to open the View Attributes settings box.

STEP 2: In the View Attributes settings box, turn the Text Node check box ON and
click the Apply button to apply the settings to View Window 1.

STEP 3: Invoke the Place Text Node tool from the Task Navigator tool box (active task
set to Text), and, in the Tool Settings window, set the Active Angle to 0
degrees.

STEP 4: Snap to the lower left corner of the border and press the O key to center the
AccuDraw compass on the corner.

STEP 5: Place the first text node at an offset from the AccuDraw compass of X = 1.35
and Y = 0.25.

STEP 6: Place the second text node at an offset from the previous node of X = 2.7 and
Y = 0.

STEP 7: Select Elements > Text Styles to open the Text Styles settings box, select
CH 7 Left Center from the Text Styles column, and close the settings box.

STEP 8: Place the third text node at an offset from the previous node of X = 1.45 and Y
= 0.1.

STEP 9: Place the fourth text node at an offset from the previous node of X = 0.0 and Y
= –0.2

STEP 10: Select Elements > Text Styles to open the Text Styles settings box, select
CH 7 Center Center from the Text Styles column, and close the settings
box.

STEP 11: Place the fourth text node at an offset from the previous node of X = 2.5 and
Y = 0.0.

The title block area of the design should now be similar to Figure P7–4 (note that
the node numbers in your design may be different than those shown in the figure).

Figure P7–4 The Text Nodes in the title block area

PLACE TEXT NODES ON THE TITLE BLOCK

This procedure places text on each Text Node in the title block.
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STEP 1: Select Settings > Locks and turn ON the Text Node lock in the submenu.

STEP 2: Invoke the Place Text tool, and, in the Tool Settings window, select the By
Origin Method.

STEP 3: Type your school name in the Text Editor box (or make up a name).

STEP 4: After you type the text, click the Data button on the leftmost Text Node to
tentatively place the school name on the node, and click the Data button a
second time to place the text on the node (the text shown on the node is only a
temporary image until you click the Data button a second time).

STEP 5: Click the Reset button to drop the image of the text from the pointer and clear
the Text Editor box.

STEP 6: Using Figure P7–5 as a guide, place text on the other Text Nodes in the
title block.

◗ Place your name to the right of ‘‘NAME:’’

◗ Place today’s date to the right of ‘‘DATE:’’

Figure P7–5 Title block text (shown with the Text Node view attribute OFF)

STEP 7: In the View Attributes dialog box, turn the Text Node attribute OFF and click
the Apply button to apply the settings to View Window 1.

STEP 8: Select Settings > Locks and turn OFF the Text Node lock.

STEP 9: Select File > Save Settings.

DRAW THE CIRCUIT BOARD

This procedure draws the circuit board.

STEP 1: Set the Active Level to Object, the Line Weight to 1, and the Color to blue (1).

STEP 2: Using Figure P7–6 as a guide, use the Place Block tool to draw the circuit board.
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Figure P7–6 Circuit board dimensions

STEP 3: If View Window 2 is not open, open it.

STEP 4: In View Window 2, turn OFF the display of the Borders level (to hide the border
and title block) and Fit the view.

STEP 5: Select File > Save Settings.

DRAW THE FIRST HOLE IN THE CIRCUIT BOARD

This procedure draws a symbol for circuit board hole number 1 and groups the
hole elements to make them easy to copy when the other holes are placed on the
circuit board.

STEP 1: Invoke the Place Circle tool Task Navigator tool box (active task set to Circles)
and, in the Tool Settings window, select the Center Method and lock the
Diameter to 0.1 inch.

STEP 2: Snap to the lower left corner of the circuit board and press the O key to center
the AccuDraw compass on the keypoint.

STEP 3: Place the circle center at an offset from the compass of X = 0.5 and Y = 0.5.

STEP 4: Draw two lines through the center of the circle, as shown in Figure P7–7.
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Figure P7–7 Dimensions of the first circuit board hole symbol

STEP 5: Invoke the Place Text tool and, in the Tool Settings window, select the By
Origin Method.

STEP 6: Type two underscores (‘‘ ’’) in the Text Editor box (to create a Data Field) and
place the text string above and to the left of the circle, as shown in the top, left
corner of Figure P7–7.

STEP 7: If the Key-in window is closed, open it.

STEP 8: In the Key-in window, type justify right ENTER, and then select and accept the
Data Field to set right text justification within the field.

STEP 9: Use the Element Selection tool to select the circle, two lines, and Data Field that
form the circuit board hole symbol.

STEP 10: Select Edit > Group to group the selected elements so they act like one
element when copies are made to create the other holes.

PLACE THE REST OF THE HOLES IN THE CIRCUIT BOARD

This procedure makes copies of the circuit board hole group to place the other
nine holes.

STEP 1: Select Settings > AccuDraw and, on the Operation tab of the AccuDraw
Settings box, turn OFF the Floating Origin check box to keep the compass on
the corner of the circuit board block while you place copies of the hole symbol.
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STEP 2: Invoke the Copy tool from the Manipulations tool box and click the hole symbol
group to select it.

STEP 3: Snap to the lower left corner of the circuit board block and press the O key to
center the AccuDraw compass on the keypoint.

STEP 4: Place a hole symbol at an offset from the AccuDraw compass of X = 2.5 and
Y = 0.5.

STEP 5: Using the hole positions table in Figure P7–8 as a guide, place the other eight
holes on the circuit board. Figure P7–9 shows the completed circuit board.

STEP 6: In the AccuDraw settings box, turn ON the Floating Origin check box.

STEP 7: Select File > Save Settings.

Figure P7–8 The hole positions table
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Figure P7–9 The hole symbols in the circuit board

FILL IN THE HOLE SYMBOL DATA FIELDS

This procedure places numbers in each of the hole symbol Enter Data Fields.

STEP 1: Invoke the Fill in Single Enter Data Field tool from the Task Navigator tool box
(active task set to Text).

STEP 2: Select the first Data Field (refer to Figure P7–9 for the numeric order), type the
number 1 in the Text Editor box, and press ENTER.

STEP 3: Invoke the Copy and Increment Enter Data Fields tool from the Task Navigator
tool box (active task set to Text) and, in the Tool Settings window, set the Tag
Increment to 1.

STEP 4: Select the Data Field that contains the number 1 to tell the tool what number to
increment.

STEP 5: Select each of the other hole Data Fields in numeric order and click one extra
time to accept the last field.

STEP 6: Select File > Save Settings.

DRAW THE HOLE LOCATIONS TABLE

This procedure draws the hole locations table in View Window 3.

STEP 1: Turn on View Window 3, Fit the view, and set focus to it.

STEP 2: Using Figure P7–10 as a guide, draw the table outline block and grid lines.
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Figure P7–10 The hole locations table dimensions

STEP 3: Use the Window Area tool to fill the view with the hole locations table.

STEP 4: Invoke the Place Text tool and, in the Tool Settings window, select the By
Origin Method and set the Justification to Top Center.

STEP 5: In the Text Editor box, key-in all the text for the left table column, as shown in
Figure P7–11.

Figure P7–11 The Text Editor box containing the text for the first table column

STEP 6: Drag the text string to the top of the left table column, center it horizontally
within the column, click the Data button to place it, and then click the Reset
button to clear the Text Editor.
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STEP 7: Using the same method as steps 5 and 6 (and Figure P7–11), place the text in the
X and Y table columns.

STEP 8: Place the text string below the table, as shown in Figure P7–11.

PREPARE TO CLOSE THE DESIGN

This procedure checks the design for mistakes, compresses it, and saves the current
settings.

STEP 1: Set focus to View Window 1, by clicking on its title bar or border.

STEP 2: Fit View Window 1.

STEP 3: Compare your design to Figure P7–1 and, if necessary, correct mistakes.

STEP 4: Select File > Compress Design.

STEP 5: Select File > Save Settings.

Note: Some companies have MicroStation set to automatically compress the design
and save settings when design files are closed.
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DRAWING EXERCISES 7–1 THROUGH 7–5
Use the following table to set up the design files for Exercises 7–1 and 7–2.

SETTING VALUE

Seed File seed2d.dgn
Working Units Master Unit=Inches, Sub Unit=Inches
Grid Grid Master = 0.1, Grid Reference = 10, Grid Lock ON

Exercise 7–1
TEXTBOOK LOGO

7-12



Chapter 7 Placing Text, Data Fields and Tags

Exercise 7–2
TERMINAL STRIP
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Use the following table to set up the design files for Exercises 7–3 through 7–5.

SETTING VALUE

Seed File seed2d.dgn
Working Units Master Unit=Feet, Sub Unit=Inches
Grid Grid Master = .5, Grid Reference = 24, Grid Lock ON

In Exercise 7–3, make your best estimate to determine the dimensions of the building
section.

Exercise 7–3
BUILDING SECTION

For Exercise 7–4, draw the structural plan and place the descriptive text. Do not draw the
dimensions.
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Exercise 7–4
STRUCTURAL STEEL PLAN
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Exercise 7–5
SITE PLAN
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