i

Attaching References

i? PROJECT EXERCISE

This project exercise provides step-by-step instructions for creating the design shown in
Figure P13—1. The intent is to guide you in using reference files to complete a design.
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Figure P13-1 Completed project design

This project creates separate design files for the following:

D Pipe rack plot plan
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D Pump foundation plot plan
D Border

D Complete design formed from references to the other three design files

Note: As you complete each step in the project procedures, place a check mark by the

N

step to help you keep up with where you are in the project.

CREATE THE PIPE RACK PLOT PLAN
This procedure creates the design shown in Figure P13-2. The pipe rack is drawn

using offsets from the design origin point.
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Figure P13-2 Completed pipe rack plot plan
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STEP 8:
STEP 9:
STEP 10:

Chapter 13  Attaching References

Invoke MicroStation via the normal technique for the operating system on your
workstation.

Create a new design file named RACK.DGN using the seed2d.dgn seed file.

Set the following design parameters:

Working Units Master Units to ' (for feet), the Sub Units to ” (for inches)
Grid Master to 0.5, Grid Reference to 2, and Grid Lock to OFF

Select Settings > Level > Manager to open the Level Manager settings box
and create the following levels:

Name=Rack, Color=White (0), Style=0, Weight=1, Display ON
Name=Text, Color=Blue (), Style=0, Weight=1, Display ON
Name=Column, Color=Green (2), Style=0, Weight=1, Display ON

Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

Set Rack as the active level. Draw the following two unconnected lines:
XY =2,0to DL =0,35

XY =0,5to DL =128,0

Make parallel copies of the two lines:

Horizontal line: 25 feet above the original line

Vertical line: 14 feet to the right of the original line

Draw a block from XY = 0,0 to XY = 28,35, as shown in Figure P13-3.
Set Column as the active level.

Draw a |-foot by |-foot I-beam centered on the lower left centerline
intersection, as shown in Figure P13—4.
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Figure P13-3  Pipe rack centerlines and perimeter
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Figure P13-4 Lower left I-beam

STEP |1: Use the Array tool to place a rectangular array with the following settings (see
Figure P13-5):
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Chapter 13  Attaching References

D Rows =2

D Columns =2

D Row spacing = 25

D Column spacing = 14
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Figure P13-5 Results of the Rectangular Array tool

STEP 12: Set Text as the active level.
STEP 13: Set the text parameters to:
D Font=3
D Height and Width = 0.125
D Line Spacing = 0.125

Note: The text size is 0.125’, so it will plot 0.125” (1/8”) high at a plot scale of '/4” = I'.

IN

STEP 14: Place all text shown in Figure P13-2.
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STEP I5:

Note: To place the symbol on the centerlines, set the Font to 15 (IGESI00I), and
place the lowercase letter q.

Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

CREATE THE PUMP FOUNDATIONS PLOT PLAN

This procedure creates the design shown in Figure P13-6. The foundations are
drawn using offsets from the design origin point.
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Figure P13-6 Pump foundations plot plan

STEP I:

STEP 2:
)
)
STEP 3:

13-6

Create a new design file named PUMPS.DGN, using the 2dEnglishGeneral.dgn
seed file.

Set up the design settings as follows:
Working Units Master Units to ' (for feet), the Sub Units to ” (for inches)
Grid Master to 0.5, Grid Reference to 2, and Grid Lock to OFF

Select Settings > Level > Manager to open the Level Manager settings box
and create the following levels:

Name=Foundation, Color=White (0), Style=0, Weight=1I, Display ON



Chapter 13  Attaching References

D Name=Text, Color=Blue (I), Style=0, Weight=1I, Display ON
D Name=Block, Color=Green (2), Style=0, Weight=1, Display ON

STEP 4: Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

STEP 5: Set Foundation as the active level. Draw the following two unconnected lines:
D XY =12585toDL=13,0
D XY =19,7to DL=0,12
STEP 6: Make a parallel copy of the horizontal line 9" above the original.
STEP 7: Set Block as the active level.
STEP 8: Draw a block from XY = 14.5,6.5 to DL = 5.5,4, as shown in Figure P13-7.
STEP 9: Make a copy of the block exactly 8’ above the original.

STEP 10: Set Text as the active level.

Figure P13-7  Pump centerlines and lower pump foundations

STEP | 1: Set the text parameters to:
D Font =3
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D Height and Width = 0.125'
D Line Spacing = 0.125'
STEP 12: Place text as shown in Figure P13-6.

STEP 13: Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

CREATE THE BORDER
This procedure creates the design shown in Figure P13-8.
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Figure P13-8 Letter-size border
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STEP I:

STEP 2:

STEP 3:

STEP 4:

STEP 5:

STEP 6:
)
)
STEP 7:
STEP 8:
STEP 9:

STEP 10:
]
]
]
STEP I 1:
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Create a new design file named BORDER.DGN, using the 2dEnglishGeneral.dgn
seed file.

Adjust the design settings as follows:
Working Units Master Units to IN (for inches), the Sub Units to IN
Grid Master to 0.1, Grid Reference to 10, and Grid Lock to ON

Select Settings > Level > Manager to open the Level Manager settings box
and create the following level:

Name=Border, Color=White (0), Style=0, Weight=1, Display ON

Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

Set Border as the active level. Draw the border and title block using the
dimensions shown in Figure P13-8.

Set the following parameters:

Text Height and Width = 0.125”

Text Font = 3

Place the text as shown in Figure P13-8.
Invoke the Fit View tool to fit the view.

Open the Saved Views settings box by selecting Saved Views from the
Utilities drop-down menu.

In the Saved Views settings box, create a new view:

Key-in border in the Source Name field.

Key-in Letter-size border in the Source Description field.
Click the Save button to create a saved view.

Invoke the Save Settings tool from the File drop-down menu to save the design
settings.

CREATE THE COMPLETE DESIGN

This procedure creates the composite design by referencing the previous design

files (see Figure P13-1).

STEP I:

STEP 2:

Create a new design file named CHI3.DGN, using the 2dEnglishGeneral.dgn seed
file.

Set up the design settings as follows:

D Working Units Master Units to ' (for feet), the Sub Units to ” (for inches)

Grid Master to 0.5, Grid Reference to 2, and Grid Lock to OFF
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STEP 3: Select Settings > Level > Manager to open the Level Manager settings box
and create the following level:

D Name=Base, Color=White (0), Style=0, Weight=1, Display ON

STEP 4: Set Base as the active level. Open the References settings box by selecting
Reference from the File menu.

STEP 5: Invoke Attach from the Tools menu in the References settings box.
MicroStation opens the Attach Reference dialog box.

STEP 6: Select RACK.DGN from the appropriate folder, and click Open to attach the
design file as a reference to the current design file. MicroStation displays the
Reference Attachment Settings dialog box.

STEP 7: In the Reference Attachment Settings dialog box, make the following settings:
D Key-in rack in the Logical Name field.
D Key-in Pipe rack plot plan in the Description field.
D Select Coincident from the Orientation list box.
D Click OK to attach the pipe rack design file as a reference.
STEP 8: Invoke the Fit View All tool to fit the view window.

STEP 9: Similarly, attach the PUMPS.DGN design file as a reference, keying-in pumps for
the Logical Name, Pump foundations for the Description and select
Coincident from the Orientation list box.

STEP 10: Also attach BORDER.DGN as a reference. In the Reference Attachment Settings
dialog box, set the following settings:

Key-in border in the Logical Name field.

Key-in The drawing border in the Description field.
Select Coincident from the Orientation list box.

Set the Scale (Master:Ref) ratio to 4 to |.

Click OK.

Note: The Scale (Master:Ref) ratio scales the border for plotting at 1/4” = 1". This
works because the border design has inches as its Master Units and the active design
has feet as its Master Units. The ratio of 4 to | means every four feet of active design
displays one inch of border reference, or 1”7 = 4, (divide both sides of the equation by 4
and you get /4" = 1').

N

STEP 11: On the References dialog box select the Border design, select the Move
References tool and drag the reference file dynamic outline until all of the pipe
rack is inside and close to the top of the outline, and then click the Data button
to place the border.
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MicroStation prompts:
Move Reference > Enter point to move from

Place a data point somewhere in the design.

Move Reference > Enter point to move to

Move the drawing pointer the direction and distance the border needs to be
moved, then place a second data point to move the reference file.

STEP 12: Set the text parameters to:

D Font=3

D Text Height and Width = 0.125’
STEP 13: Fill in the title block text, as shown in Figure P13-I.
STEP 14: Invoke the Fit View tool to fit the view.

STEP 15: Invoke the Save Settings tool from the File menu to save the design settings.
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DRAWING EXERCISES 13-1 THROUGH 13-5

Use the following table to set up the design files for Exercises 13—1 through 13-5.

SETTING VALUE

Seed File seed2d.dgn

Working Units Master and Sub Units to inches

Grid Grid Master = 0.25, Grid Reference = 4
BORDER

Draw the border shown in the figure. This border is used in the following exercises.

1. SET THE WORKING UNITS TO 1:10:1000 AND NAME THE MASTER UNITS “IN”

2. DRAW THE BORDER AND TITLE BLOCK. BUT DO NOT DRAW
THE DIMENSIONS OR THESE INSTRUCTIONS

3. FIT THE VIEW AND CREATE A SAVED VIEW NAMED "BORDER”
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CREATE A DESIGN FILE

Reference the border in the new file, then reference the machine part drawings created in
Exercises 4-1, 5-2, and 12-3. Clip the boundary of each of the machine parts, scale each
one to one-half its true size (Master:ref 0.50000:1.00000), and then move each one inside
the border.
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Open the front elevation design drawn in Exercise 7-3. If the design includes a border, de-
lete it. Reference the border design file’s “Border” saved view at an attach scale of
1/8” = 1" (Master:ref 4.00000:1.00000).
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Exercise 13-4

Draw the two parts of a flow diagram shown in Figures Ex|3—4a and Ex|3—4b. Put each
part in a separate model. Place the ends of the off-page lines at the XY coordinates shown
in each figure. The dimension shown in the first figure is intended only to provide a feel for
the size of the diagrams. Do not draw the dimension or XY coordinates.

XY=17,11.1
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Figure ExI3-4a Flow diagram A
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Figure Ex13-4b  Flow diagram B
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Chapter 13  Attaching References

COMPLETED FLOW DIAGRAM

Create a design file, and then reference the two flow diagram parts A and B to create the
complete diagram. Reference the border and scale it to encompass the complete flow dia-
gram, as shown in the figure.
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